Problem with Picture Frames (SR17)

Since the last update i can’t drag jpgs into to viewport.
Before when I dragged a jpg into the viewport it gave me the option to use it as a picture frame. Now nothing happens.

When I use the picture frame tool it works as intended, but dragging it into the viewport was much quicker.

Am I doing something wrong or is it a bug?

1 Like

Hi Jonas - it doesn’t sound like you are doing something wrong and it works as expected here but this is the second report of this behavior today so something might be going on.
Could you update to the latest Service Release - currently SR18 - and try again?

Thanks for the quick response.
I updated to SR 18 and unfortunately it still doesn’t work

Hi - Is this with a specific file that it doesn’t work or is it the same with any picture?

Any picture.

I tried JPG and PNG.

PDF works as intended

Hi Jonas - can you run SystemInfo in Rhino and post the results?

@didid - are you running VRay by any chance?


Rhino 6 SR18 2019-9-23 (Rhino 6, 6.18.19266.14201, Git hash:master @ 3d84f88dec99b2f4e8b7497e739ed2adc2ba8ef6)

License type: Kommerziell, Build 2019-09-23

License details: Cloud Zoo. In use by: Stephan Jonas (didid)

Windows 10.0 SR0.0 or greater (Physical RAM: 12Gb)

Machine name: BD-PC

Non-hybrid graphics.

Primary display and OpenGL: NVIDIA GeForce GTX 680MX (NVidia) Memory: 2GB, Driver date: 5-1-2017 (M-D-Y). OpenGL Ver: 4.5.0 NVIDIA 382.05

OpenGL Settings

Safe mode: Off

Use accelerated hardware modes: On

Redraw scene when viewports are exposed: On

Anti-alias mode: 4x

Mip Map Filtering: Linear

Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation

Render version: 4.5

Shading Language: 4.50 NVIDIA

Driver Date: 5-1-2017

Driver Version:

Maximum Texture size: 16384 x 16384

Z-Buffer depth: 24 bits

Maximum Viewport size: 16384 x 16384

Total Video Memory: 2 GB

Rhino plugins

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.18.19266.14201

C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”

C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”

C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”

C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”

C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.18.19266.14201

C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”

C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”

C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.18.19266.14201

C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.18.19266.14201

C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”

C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”

C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Thanks, Jonas!
In the other reported case, running Rhino without V-Ray made the problem go away - could you give that a try as well?


Hey wim,

You were right. Running rhino without VRay solved the problem.
So its probably a problem with the latest VRay update.

Hi Jonas, it sure looks like that, yes. Please contact Chaos Group about this issue.
CC: @Nikolay

It was my understanding that Rhino handles the supported drop event without calling the plugin’s implementations. However that is based only on dragging .3dm files :frowning:

it was a quick fix.

As a temporary workaround, switching the current render engine to Rhino Render will restore the inhibited functionality without the need to disable V-Ray altogether.

1 Like