Problem with Graphics Card after Rhino 5 update on 10-1-2014

Problem after update:

I found that after an rhino 5 update yesterday, that my video FirePro V7900 video card is messing up.
Jeff LaSor can you let me know why? John Brock referred me to you.

At first, I noticed my gumball was missing its arrows. If I clicked on the line to move gumball, then the arrows appear. Selecting the “Do not use OpenGL for feedback” in options fixed the problem but
when I zoom in close, I get weird view of overlapping lines.

I now Deselected in options, the “do not use openGL for feedback” to show you the missing arrow tips on the Gumball, but now have no movement on my screen at all with it Deselected.
The Tools seem to be working without it selected, but the viewport is frozen.

Please help. Thanks.

Did you also happen to update your video drivers? I ask because others are complaining about similar issues, only they don’t appear to be updated to SR10 RC, and they’ve only updated their video drivers… Rolling back to the previous video driver seems to have solved the issue for some.

Some minor tweaks were made to SR10, but I’m having a hard time understanding how those tweaks could be causing your situation. I think I have a V7900 here, so I will see if I get similar problems… In the mean time, please verify which version of the AMD Catalyst drivers you have installed.


Also, what display mode(s) are you using? Have you tweaked any of the settings in those modes? We need to make sure we’re both working with the exact same thing so I suggest that for now you “Restore Defaults” the modes you’re working in just to rule out any issue there… If that seems to make the problem go away, then we’ll have to start digging into which settings is causing this.


Thanks jeff. No, I did not update the Driver for the Vid. card.
I mostly use Ghosted view.
My current driver is: 8.830.5.4000 Date. 5/20/2011

Should I update driver? I will wait for your response.

Best. chad

Please hold off from doing anything at the moment, until I can get a system setup and running using the V7900. What OS are you using?


I will Restore defaults in the meantime…
in the tool options the names where blue and changed to black when i "restored defaults."
Checking result now…

NO change. Viewport is frozen when “do not use open GL for drawing feedback.” is Unchecked.

Let me know what you find.

windows 7

Ok thanks.

Your drivers do seem to be a bit out of date…but I realize that things have been working for you and that you’re now only seeing problems after the SR update… But since I will be installing the latest drivers to test with, I suggest you do the same…

These are the ones I will be installing:

Since you’ll probably be done before I can get a machine setup, please let me know if those make any difference.


will do.


the new driver has Not affected any of the issues. Still getting same result frozen viewport when deselected "do not use opengl for feedback…
My contact is 714-893-0999 ext. 30 if you want to verbally check with me.


Definitely some weird stuff happening. Just performed a simple move command and all my tool bars relocated to the center of my screen.

That one you can fix in the Hydravision controls - I’m not sure where the exact setting is but it’s in there someplace, I’ll see if I can find a better reference.

It looks like this is it:

First, right-click an empty part of the desktop and select ‘Catalyst Control Center’. Click the HydraVision tab on the left, then choose Desktop Manager. Disable dialog repositioning in the Dialog Control section.
Click Apply to save your changes and the volume control should return to the taskbar.


Wow…ya something is definitely not right… I’m seeing the missing gumball arrows, but only in Ghosted mode, all other modes seem to show them fine. I’m not seeing any kind of freezing viewports or lockups though…

Can you walk me step-by-step what you’re doing up until the point your viewport freezes.


freezes when i de-select the “do not use the openGL for drawing feedback.” I never have that selected, but it is making the gumball work correctly when it is checked. when i uncheck it, now none of the modes in the viewport move. the camera is moving around, cuz when i recheck the box, my model view caamera angle is differenct.

and should i perform the hydra vision that Pascal recommended.?

it wont let me “apply” the change. when i uncheck the box, the apply button goes grey.
But… when i close the amd pro control center and open it back up, it is UN checked. So seems is “applied” maybe.

I was prompted that update at the end of my day yesterday and immediately notice the problem with the gumball. I caught John B. just before close yesterday, and he was who instructed me to turn on the “do not use open gl” box.

My toolbars just moved Again.
I had No problems before that update.


Ok, it sounds like we’re chasing three problems here…

  1. The arrows not showing up (which I can reproduce here on any card using Ghosted mode).

  2. Moving toolbars

  3. Unchecking the “Do not user OpenGL for drawing feedback” option is freezing up your system.

The latter one is most certainly an OpenGL reinitialization issue, and may have already existed on your system, you just never knew it because you never tried checking/unchecking that option.

I really wish we would stop recommending that option as “fix”…it is there merely to help diagnose where potential feedback drawing problems occur, or if feedback drawing is the cause of whatever the problem is we’re looking at… It should never always be CHECKed…but I digress…

I have found the problem and will commit the fix shortly… For now, please keep that option UNCHECKed and either work in modes other than Ghosted, or live with the missing arrowheads until the next SR10 RC is released.

As for the moving toolbars, I’ll let Pascal jump in on that one…It has nothing to do with the viewports or Rhino’s display pipeline, and it’s related to AMD’s CCC settings…or perhaps something John M. changed… Pascal, you might want to bring him in on this one as well.


I to had the same on my system, but have had to work thru it after a total crash. Todays SR seems to be doing better. Thanks Jeff, Pascal, et al.

Hi Chad- so, in the end, is the moving toolbar problem still there or did it sort itself out?