Problem with display modes

Hi!
Please help me to solve some minor problem with my Rhinoceros installation.After the final update i can use only the standart Rhino display modes.Hitting every other like neon,tsShiny or custom one give me that:
Unknown command: tsShiny
Unknown command: RaytracedwithNeon
Mode ( Wireframe Shaded Rendered Ghosted XRay Technical Artistic Pen ):
?
Someworkaround is to switch modes from the right display bar and everyth is messed up?
If I start RG only I can switch properly every display mode?Any recom…?
Win8,i7 intel HD 4000 Rhino 5 sr10 x64.the same problem is not present in x32 version?

The display modes like Neon or tsShiny will rely on the associated plugins so check that Neon and/or Tsplines are installed and active to use these modes. Rhino leaves the display modes in your options even if the plugins are uninstalled or missing. You have to remove them manually in Options>Display Modes if you don’t want them in the viewport display mode list.

All display features in Rhino 5 like those in Rendered or Technical modes may not work properly with the Intel HD GPU as well. These are known to have limited OpenGL support.

So it may be the intel driver?I use them almost a year in this config without problems.Basically they work but not from the viewport dropdown menus,instead I use the right vertical display bar-the only working way?In x32 all is fine and in rhino gold only too?Thanks BianJ!

Hi Kokomoko - I think it’s just that the expected plug-ins are not loading. Is TSplines working but just not the TS display modes? If it’s not working you might just want to drag and drop the plug-in, as well as Neon, onto Rhino to force them to load- that’s where I’d start at least.

-Pascal

I meant that you should just be aware this model GPU is not great for Rhino but not that it had anything to do with the display modes for TS or Neon. Neon also runs on the CPU so that’s not going to use the GPU like other modes.

I think you might not have the 64 bit versions of the Neon and TS plugin installed (If TS makes one for x64… I can’t recall). Check Options>Plugins in Rhino 5 to see if these plugins are loaded and enabled.

All plugins are loaded and working.From all the menus in rhino I can switch only between standard display modes/wire,shaded,rendered,etc pen.The custom modes show unknown command.Thats in x64 Rhino.The only way I discoverd is to use the right tab with display active viewport and to change between all modes.This way work-but Neon shows tsShiny,and my custom mode fire up Neon??In Rhino x32 all is fine.When I start only RhinoGold its the same-all work.

I would delete the modes from Options > View >Display modes, and then restart Rhino and force (hopefully) the plug-ins to make new modes.

-Pascal

Will try it Pascal…

Nah,nothing,it show this;
Mode ( Wireframe Shaded Rendered Ghosted XRay Technical Artistic Pen ):
Unknown command: tsShiny
Unknown command: RaytracedwithNeon
and in Rhino x32 all is just fine.Another fail in x64 is place image1:1 from RGold,in x32 this works too!

Well, just to be clear, these are not commands in themselves - use SetDisplayMode RaytracedWithNeon, etc.

-Pascal

Sorry,didnt work in the command line too.Just show only the standart modes and again unknown command.Reinstalled Neon ,but no chance.

Hmmm - so your current state is:

  • Only default display modes show in Options > View > Disdplay mode.
  • TSplines is loaded and working.
  • Neon shows as loaded & enabled in Options > Plug-ins (?)

is that all correct?

-Pascal

Correct Pascal.

@BrianJ, any ideas?

-Pascal

I would run the x64 installer for each of the plugins again with Rhino closed and choose the repair option if that is a choice. If that doesn’t help, I can try and figure it out in a remote session, @kokomoko private message me on this forum and go to www.Rhino3d.com/help to download the remote app and get an access number for me to connect.

@andy

Can you take a look at this users machine please? I suspect this is a conflict between TS and/or RG and Neon but it’s not clear. One of the Tsplines display modes in x64 v5 SR10 would launch Neon but Neon itself will not run from it’s own display mode. The command line just asks for the mode you’d like to use and Neon isn’t in the list. I repaired and also uninstalled Neon and installed fresh after a reboot. I also deleted the Neon display mode to force the Neon installer to make a new one but no luck. Additionally I load protected TS and RG.

Hi guys, have you found the solution for this? I’m having the same problem. I only have the "Wireframe, Shaded, Rendered, and Ghosted XRay. All the other options are there, but I get “unknown command” feedback. For instance, for Artistic I get… “Unknown command: Artistic”

Hi @arturaoki - the quick and dirty solution is close Rhino and using RegEdit delete the following keys. (Please be sure not to touch anything else in RegEdit)

32bit: HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\5.0\Scheme: Default\Options\DisplayAttributesManager
64bit: HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\5.0x64\Scheme: Default\Options\DisplayAttributesManager

Are you running any non-default plug-ins, like maybe TSplines?

thanks,

-Pascal

Hi there,many thanks to McNeel team,with the last dujour update from march,finally no problems with display modes!Now I realise how disturbing was this for my workflow…Thanks!