Problem with ArrayCrvonSrf

I’ve been trying to use the ArrayCrvonSrf command to position some screws on a “windshield” surface. I was able to do it once and every time I do it again the screws come out perpendicular to the surface instead of parallel. I have a feeling that the “trick” is where exactly I click on the screw for the base point… but can’t figure out where it should be. I’ve also tried changing the Dir of the surface and that doesn’t seem to help.

I’ve made a very short video that shows my steps and have attached the file to work with. Working with Version 7.SR.27 on Windows 10. Thank you

ArrayCrvonSrf.3dm (3.9 MB)

Hi Cosmas - the command maps the current cplane normal to the surface normal - so you need to start wirth a cplane parallel to the base of the object.


I’m not sure I know what you mean, Pascal. When you say “the command maps the current cplane normal” are you referring to the cplane that the object is sitting on? And when you say “you need to start with a cplane parallel to the base of the object” my cplane is parallel to the base of the object isn’t it?

Hi Cosmas - when you pick the base point for the array, the CPlane that is current in that view determines how the object wiull be oriented relative to the target surface - the Z of that CPlane will map to the target surface normal, so if the object is oriented on the CPlane the way it should be oriented on the target surface, you should be good… dunno if I’ve clarified or muddied - I can make a video clip a bit later in the day.


Got it, Pascal. I see what you mean - my cplane was not parallel to the object I was trying to array. Thank you :slightly_smiling_face:

solved ?