Problem with 3dm export

Hi!

I have a script that opens my injection mold designs, selects each of the parts, positions and exports the separate parts to the machining sector.

Running the script on Rhino V5, opens and exports the files in 3dm V5, the machining sector opens the files normally on Powermill 2020.

The same project, when running the script on Rhino V7, opens and exports the 3dm V5 files, the machining sector cannot open the files.

I’ve tested different projects and exported manually too, always the same result.

Open the project in Rhino V5 and export 3dm in V5, you can open it in Powermill 2020

Open the project in Rhino V7 and export 3dm in V5, cannot open in Powermill 2020.

Does anyone know what could be happening?

Thank you so much for everyone’s attention.

Tks
Maico Thiesen

Hi @maicoths
I’ve run into this problem when I save as v5 file type out of v7. For me Rhino always saves the file as a v7 file the first time I save it even if I choose v5 type in the dropdown. Notice no dialog box pops up to save as a v5 file type on the first save, I then save the file again as v5 and the dialog pops up letting me save as v5.

In v7 try manually to save a v5 file but save it twice see if on the second attempt the dialog box pops up allowing you to save as v5 type then try to import that into Powermill.

I save to V5 for my cutter on win 95 and I found a number of times Rhino was saving as a V7 type and couldn’t open in v5.
Don’t know if this is helps since you’re using a script but I thought I’d throw it out there.
RM

Hi @3dsynergy

Thanks for your answer, but that’s not the problem.
The exported file from V7 to V5 can be opened in Rhino V5, but it doesn’t open in Powermill 2020, only if I open it in Rhino V5 and save it again as V5, in this case the powermill can open the file.

This is the command I use in the export script, I chose to save in V5 and it seems to work because I can open the file in Rhino V5.

StrCommand = "-Export S V 5 " + StrNameDir + “\tmp” + StrNameFile + “.3dm enter”
Rhino.command StrCommand

I really don’t understand what could be going on

Best Regards
Maico Thiesen

Below is a part of the command history after running the script, I think it is working normally and that the problem with the file may be in the conversion from Rhino V7 to V5

Command: -SelColor
Select objects with target colors ( Color RGBA ): C
Color to select <0,191,0> ( ColorPicker ): 205,205,0
No objects added to selection.
Command: Selnone
Command: -Selcolor
Select objects with target colors ( Color RGBA ): C
Color to select <205,205,0> ( ColorPicker ): 100,100,100
7 surfaces added to selection.
Command: -Export
Save file name ( Version=7 SaveSmall=No GeometryOnly=No SaveTextures=Yes SaveNotes=No SavePlugInData=Yes Browse ): S
Save file name ( Version=7 SaveSmall=Yes GeometryOnly=No SaveTextures=Yes SaveNotes=No SavePlugInData=Yes Browse ): V
Enter version of file to save <7>: 5
Save file name ( Version=5 SaveSmall=Yes GeometryOnly=No SaveTextures=Yes SaveNotes=No SavePlugInData=Yes Browse ): P:\CLIENTES\B\BoaOnda\2153\Piloto_35x\Piloto_35x_5\Cavidade\tmpTampinha.3dm
File successfully saved as Rhino 5 file P:\CLIENTES\B\BoaOnda\2153\Piloto_35x\Piloto_35x_5\Cavidade\tmpTampinha.3dm.
Command: Selnone
Command: Selnone
Command: -Selcolor
Select objects with target colors ( Color RGBA ): C
Color to select <100,100,100> ( ColorPicker ): 101,101,101
No objects added to selection.

Hi!

Apparently the problem has been resolved.
Updated the Exchange version of Powermill 2020 and this made it able to read exported files from Rhino V7 into V5.
But I still don’t understand why the previous version could read native Rhino V5 files and could not read Rhino V7 files exported as V5.

Best Regards
Maico Thiesen

Hi @maicoths,
Wow that’s a weird one, I have the opposite I have to export twice for the V5 option to work the dialog doesn’t come up for me the first time and those files for me won’t open in V5. I think I’ll try the scripted version on an icon instead.
Perhaps you need to make sure no other options are checked when you export but it sounds like another v7 hiccup.
You’ll need to send an example file to tech I think they will need that in order to diagnose.
RM