Problem when rendering with Toucan on Mavericks


#1

Hey guys!

I am running Mavericks on an iMac with 16 GB internal memory.

Yesterday, I experienced a problem when trying to render an image with the built in Toucan Renderer on Rhino Mac.
I had a look at the Taskmanager during the process and could see that in the beginning Rhino occupied about 8-9 GB of memory while it was rendering.
At some point (approximately after half the image was rendered) an error message occured that said the system had run out of memory and I should close all my programs. Now there was a task called kernel_task which consumed up to 9 GB of my virtual memory and displaced Rhino to the second position with “only” about 2,5 GB left. Rhino did not render further at this point and I could only see half the image.
There was no way around ending Rhino and the rendering process. I tried it a couple of times, including several system restarts. Always the same result.

I talked to the Apple support and they suggested since the problem only appeared with Rhino (so far) it might rather be an issue of the renderer than a problem of the operating system itself. kernel_task seems to be a basic element of the OS that can not be interrupted, ended or changed.

So my question is: did anyone else have this problem? Is it possible that there is an interference between Toucan and Mavericks for example? Is there any solution for that? Because basically, I can not render anything now.

Thanks for any answer.


(Brian James) #2

Hi Lion,

I haven’t heard of this issue before, can you render any other file? I’m wondering if this specific file has geometry in it that is causing the issue. If you can share the file with us please send it to tech@mcneel.com or use www.rhino3d.com/upload if it’s too large to email. Please make sure to include any texture maps as well that may be used in the materials on the model. My last thought is in regards to resolution, what dimensions are you rendering out at and does it work at a smaller setting?


(Marlin Prowell) #3

It sounds like you are trying to generate a very large image. What are the resolution and antialias settings of the image you are trying to render? These can be found on Render > Render Properties > Basic.