Problem Loading GPU, GDI Generic?

unhandled

#1

Dell XPS15 9560
Intel HD630 (Driver date: 2017OCT17 ver: 22.20.16.4836) and
GTX1050(Driver date: 2018JAN03 ver: 23.21.13.9065)
Both running ok according to Device Manager
(Also use external GPU Gaming Box GTX1070, but not connected)

Clean reinstalled GTX1050 driver yesterday and worked, but again back to GDI Generic?
Same for V5 so probably PC specific… anyplace where I can start to look to fix?
(sorry for many post on pc specific stuff everyone, just couldn’t fix it this time)

Already tried this:
www.dell.com/support/article/jp/ja/jpbsd1/how10586/how-to-make-the-nvidia-graphics-processor-the-default-graphics-adapter-using-the-nvidia-control-panel?lang=en

Adobe Photoshop seems to recognize the HD630 at least…

Rhino 6 SR1 2018-1-23 (Rhino 6, 6.1.18023.13161, Git hash:master @ 92a80e9e2b29e4670a94deb0d656e234ca1fe036)

Windows 10.0 SR0.0 or greater (Physical RAM: 24Gb)

GDI Generic (OpenGL ver:1.1.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: 10-17-2017
Driver Version: 22.20.16.4836
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


(Nathan 'jesterKing' Letwory) #2

As a quick test I’d rename %APPDATA%\McNeel\Rhinoceros\6.0 before starting Rhino. If that works please zip up the renamed folder and send to me.

/Nathan


#3

Do you mean change “APPDATA” to something else?
Got an unexpected error and couldn’t change it…

Changed McNeel to McNeelX and launched Rhino V6 but got the same GDI Generic driver…

Which folder should I send to you? Everything under APPDATA?
…around 4GB.

I’ll try disabling/enabling GPUs if that does anything…

[Edit:Adding info below this line]
Disabled the GTX1050 device from device manager and

now Rhino can see the HD graphics
20180130Sysinfo.txt (1.6 KB)
and enabling again, only shows the GDI Generic…


(Nathan 'jesterKing' Letwory) #4

No, only the 6.0 under %APPDATA%\McNeel\Rhinoceros

But to me it sounds you need to competely uninstall your nvidia drivers and reinstall them. Perhaps try disabling the Intel GPU in the BIOS as a separate test?


#5

Ok Will send you the files.

Seems like as you said, I need to do a complete uninstall/reinstall.
When GTX is enabled photoshop also can’t detect intel HD gpu either…

in the Bios there was no way to shut down the intel GPU, I guess as it’s a notebook and itel GPU seems to be running the display…

If there are folders that you know which needs to be deleted manually please let me know…

Sending you the data in separate message.


#6

Great!

Uninstalled everything Nvidia.
So from application that is bundled with the Geforce driver. like 3D Vision, Geforce Experience… etc…

Also did Device Uninstall and deleting of all drivers…

rebooted then installed ver 390.77 Nvidia driver.
and back to using GTX1050!

not going to update driver until something fails next time rather then letting the latest update info do it…