Problem importing V4 .tb work space into V5


When importing my old V4 (.tb) workspace into V5 (Win64) some of the tool button bitmaps fail to import, while others import just fine. In the case of the ones that don’t, the left/right button commands are there and seem to work properly, but there is just a large grey “X” displayed in place of the proper button bitmap. I’ve tried just opening the .tb workspace in V5 as well as using the import option, but get the same problem either way. Any suggestions on how to correct this? - Derek


Hi Derek,

somewhere during the beta cycle, it has been decided to remove the functionality to use custom sized buttons. If your button bitmaps are not 16x16, 24x24 or 32x32 pixel size, the will get truncated or resized. I´m afraid. What is the size of the V4 *.tb button images which fail to import ?

Also, for backup purposes, note the file format change, .tb has been in V4, now if you open it, you should get a new file with .rui extension.



All my V4 .tb buttons are 24 X 24, so I can’t figure out why some tool bars within the .tb workspace file import just fine, while other tool bars are missing all their button bitmaps. In other words, what is happening is that either “all” the buttons on a particular tool bar import correctly with their respective bitmaps or I get a tool bar with “all” the buttons missing their respective bitmaps. It’s either all or nothing depending on the toolbar in question. To confuse things further, on one occasion my popup toolbar imported just fine (with all it’s respective bitmaps), but in an attempt to get some of the other problem tool bars to display correctly I deleted the workspace and opened/imported it again, only to then have the popup toolbar missing all its button bitmaps. Go figure???

I spent countless hours creating these custom button bitmaps, so I sure hope there is a way to resolve this. I’ll attach the V4 .tb file for your review.

Oh, as you stated, V5 does convert the imported .tb file to a .rui extension. - Derek


Here’s the attached .tb file for my last post. I had to change the .tb extension to .rui to attach it here, so change it back to .tb before you try it in V5. - Derek V4_.tb_workspace.rui(772.9 KB)


Just an update, Now some buttons within a particular toolbar are importing ok and some are not. I’m lost! :frowning:



Hi Derek,

i feel your pain, this all looks buggy to me. I´ve been renaming the file to V4tbworkspace.rui to get rid of the point in the filename. Then closed all my workspaces and opened yours. Upon opening it, i saw these errors on the commandline:

Can not add item Insert Window to toolbar Architecture, can not be linked to itself
Can not add item Window CutOuts to toolbar Architecture, can not be linked to itself
Can not add item Update history on selected objects to toolbar History, can not be linked to itself
Can not add item New to toolbar Main_2, can not be linked to itself

The images are missing for many toolbars here too but i think there are duplicated toolbars as well, eg. with names like “Architecture”, “Architecture 00”, “Architecture 01”. Then i´ve closed the workspace completely and created a new empty one with a new name. This created a single empty toolbar with a tab and one button inlcuded using a smiley :wink:

Then i´ve clicked on import (unter toolbar properties) and selected your tb file. It took a bit of time, gave me the same error messages and opened all toolbars as tabs. Only 2 toolbars where empty, the popup was there. I guess you´ll need to arange things further and let us know first if the duplicated toolbar names where actually there or if they have been created by Rhino during import.

Derek_Toolbars.rui(6.3 MB)

The workspace file above has not to be renamed, it`s saved as rui file. @andy note the file size change after saving as rui, is this expected ? What do the errors mean ?


(Andrew le Bihan) #7


This so doesn’t have anything to do with me - but it does have something to do with John Morse - who doesn’t even seem to be logged into this thing. I’m going to shame him anyway. And just to make sure he sees it, I’ll tag @stevebaer who sits pretty close to him.



“Architecture”, “Architecture 00”, & “Architecture 01” are all pre-existing toolbars in the .tb file I sent; however, there may be some duplicate buttons in them. I’m not sure what pop-up you saw when you viewed the rui workspace you posted, but the one I saw when I downloaded it was not my pop-up toolbar. Mine looks like this: - Derek


Hi Derek,

your popup toolbar is in the rui file i´ve posted and looks identical as your last image. I´ve just opened the workspace again for verification. To open your workspace file, i´ve closed all other workspaces first. This time, i got no error messages in the commandline. The only toolbar which is empty is named “Toolbar 07”, all others come in with icons and commands.

Do you see something different ?



yeah, sorry. I´m just getting old :wink: However, while i´ve been trying to reproduce Dereks problem, i´ve found other quirks. Looks like the tooltip of a button somehow gets interpreted twice, from different sources. I have a button which displays a different tooltip when the toobar/button is shown as tab and when it is shown as a menu item. The tooltip which is shown for the menu item seems not accessable for the user.


(Steve Baer) #11

@JohnM has an account on discourse Andy. John, can you take a look at this post when you get back to work next week?

(Andrew le Bihan) #12

OK -that’s odd. I typed at-John and it didn’t show up, so I gave up.


The only way I could get the original tb file to import into V5 correctly was to divide it into two parts. I now have two separate rui files that each display correctly in V5; however, no matter what I try, I can not merge/import the two rui files into a single rui file without the imported portion missing its button icons/bitmaps. I need all my toolbars in one single rui file so I can establish the appropriate button/toolbar links.

Unfortunately I’ve spent way too much time last night editing each of these separate rui files to now use the rui file that Clement posted for me the other day (which I did finally get to work BTW - THX).

So, I guess what I need now is to ask if anyone out there can successfully merge/import the two rui files that I will attach to this post into one single rui file with “all” tool buttons icons/bitmaps displaying correctly? Maybe I’m missing something obvious here, but for the life of me, I can’t seem to figure out how to get this to work properly. Any help is definitely appreciated. - Derek

Derek_Part_1.rui(4.0 MB)

Derek_Part_2.rui(2.9 MB)

(Pascal Golay) #14

Hi Derek- please try opening the attached RUI file, on its own- do the toolbars look correct? (Only some are open as I saved it). MB)



Thanks Pascal - That file’s working just great! I sure appreciate it. Did you have any trouble getting “part 2” to import properly into “part 1?” What was I doing wrong? I probably tried to import it over a dozen times without success. - Derek


Hi @Pascal - Did you catch my last post/question on this thread. I’m trying to figure out what I’m doing wrong here. No matter what I tried, I couldn’t get either of the two rui files to properly import into the other. Any suggestions?


(Pascal Golay) #17

Hi Derek - no it seems to work just fine… I am not sure what I did that was special. I opened part 1, saved it, then imported all the toolbars from part 2. I’ll run through it again and give you a blow by blow, but I think that was it.