Prints black from perspective view

unhandled

(Joe Babb) #1

If I print from Front, Top, or Right in this file everything prints as it should. When I try to print from the perspective view, it starts out okay and then fills about 7/8 of the page with black. I’m running Rhino6 commercial on Win 8.1. I can print PDF and then print that PDF just fine. It’s only when I try to print directly from Rhino.
Paschal-candle-holder-3leg-1218apr.pdf (157.8 KB)
Haven’t tried printing perspective wireframe or pen. Could this have something to do with render? Seems like a bug.


(Joe Babb) #2

Curious why I’ve had no repsonses to this problem. It is definitely a bug in Rhino6. It happens with PEN as well as RENDERED from the perspective view. I have no problem printing from the other views.


(Nathan 'jesterKing' Letwory) #3

You may want to post the contents of Help \Rightarrow System\;Information so we have an idea of what we’re talking about.


(Joe Babb) #4

Here you go.
Rhino 6 SR3 2018-3-31 (Rhino 6, 6.3.18090.471, Git hash:master @ b32d93f452fce970e96deb46bfc68b075f06b290)

Windows 8.1 (Physical RAM: 7.9Gb)

Intel® HD Graphics 4400 (OpenGL ver:4.3.0 - Build 10.18.14.4414)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.3
Shading Language: 4.30 - Build 10.18.14.4414
Driver Date: NA
Driver Version: NA
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: n/a

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

This problem is not unique to the file I posted earlier. It happens with other files also. Wireframe prints fine from perspective view, but anything like Artist or Rendered screws up. I think I mentioned before that I can print to PDF just fine as well. It is only when I print directly to the printer.


(Nathan 'jesterKing' Letwory) #5

This is a pretty old driver, for the 4400 there is one from May 4th, 2018 (check the readme for this before installing). You may want to try updating that, if that is supported by your platform.

Are you running this in a bootcamped Windows?


(Joe Babb) #6

I have no idea what bootcamped Windows is. I bought this Dell laptop with Win 8.1 on it a few years ago.


(Nathan 'jesterKing' Letwory) #7

Ok, just wondering. The Intel HD Graphics 4400 sofar I had only seen on mac machines. Did you check if you can update the GPU driver?


(Joe Babb) #8

I’ll try to find time to see if I can update the driver. In the meantime, here are two scans of prints. I took the file from Rhino6 and saved it as Rhino5 and printed the perspective view Artistic just fine.
persp-Rhino5.PDF (94.9 KB)
Then, after I got an update from Rhino6 I printed the same thing and got
persp-Rhino6.PDF (156.0 KB)
Can anyone say definitely it is the graphics driver? Why should that matter?