Printing seems to be broken here

hi all,

I’m trying to print something from V7 and I get a blank preview. It happens in any file, like this:

If I save the file as V6 and open it in Rhino 6 it’s working fine:

Any ideas what I could try to fix this?

Thanks,

Gustavo

Any third party plug-ins running?

capture_gf_120530AM_200318

Try disabling them all and restart Rhino to see if it makes a difference. Then we can figure out what to try next.

I did that and same problem. I double checked: they are unloaded.

capture_gf_124659AM_200318

Are you using the latest V7 WIP? There was a bug that I fixed in this area about two or three weeks ago

yes, version (7.0.20071.5245, 03/11/20), it’s about a week old, but not newer version out yet.

Huh, Rhino Render not a plug-in that ships with Rhino? Sounds like a bug to me.

Also I believe Mesh2 is one of our own plug-ins.

Hi Gustavo - I downgraded to the version that you are running and can’t reproduce this on my system with a simple rectangle in a new file from a factory-default template. I’m printing to the Rhino PDF printer.
Could you provide a file that we can check?
And please also your current SystemInfo data…
-wim

I notice that your V7 screenshot shows raster and your V6 screenshot shows vectors. Any difference if you toggle that setting on either version of Rhino?

hi Steve,

From my V7 WIP print/print-preview doesn’t work in both vector or raster mode.
From V6 it does work in both vector/raster mode.

Best,

Gustavo

Hi @wim,

file is here:
workshop_floorplan02_gf_200207.zip (361.2 KB)

system info here:

Rhino 7 SR0 2020-3-11 (Public Build, 7.0.20071.05245, Git hash:master @ 9de0cf84238aa0c334831df29d24be49fa879000)
License type: Commercial, build 2020-03-11
License details: Cloud Zoo. In use by: Gustavo Fontana (Fresco Design)
Expires on: 2020-04-25

Windows 10.0 SR0.0 or greater (Physical RAM: 1.3e+02Gb)
Machine name: PRECISION7740

Hybrid graphics system.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 9-25-2019 (M-D-Y).
Primary OpenGL: NVIDIA Quadro RTX 5000 (NVidia) Memory: 16GB, Driver date: 7-7-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 431.45

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-7-2019
Driver Version: 26.21.14.3145
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 16 GB

Rhino plugins
C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” 7.0.20071.5245
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino WIP\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20071.5245
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20071.5245
C:\Program Files\Rhino WIP\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.0.20071.5245
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20071.5245
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”

I tried using that, different printers, any one this below I change still does not change the results:

I also tried just printing and see if something comes out and this is only a preview problem, print is a blank page in a situation where I know I should be seeing content.

G

One more thing: this problem is not file specific, I tried with a file from a default template and a cube, and it still happens.

Let’s try the following to see if there is something in your settings/display mode customizations that may be causing problems.

  • close all running instances of Rhino
  • open file explorer and rename the file
    C:\Users\<username>\AppData\Roaming\McNeel\Rhinoceros\7.0\settings\settings-Scheme__Default.xml
    to something like
    settings-Scheme__Default.old
  • Start Rhino 7 WIP and try to print

If that works, please send be the settings-Scheme__Default.old file. You can rename the settings file back to .xml to get all of your customized settings back.

hi Steve, that worked! here’s the .old file (inside .zip) settings-Scheme__Default.zip (9.4 KB)

Thanks,

G