Print Layout ISO 7200 technical drawing not exact on paper


i know that printing issues are here since the beginning of time but annoying nonetheless :no_mouth:

a project requires a Layout-print in ISO 7200 for technical drawings (germany) on A4
ISO margins are:
left: 20mm
upper, lower and right: 10mm
on paper for the frame.

Layout print,
Setting ‘View and Output Scale’ to Layout -> Margins and Position -> Position: Centered is greyed out (as it should be since its a layout print) and deselected.
‘Offset From’ however is still active and can’t be disabled nor set to ‘no offset’.
Changing the offset visibly changes the preview and the printed frame position about 1.2 mm to the top/right/left/bottom (depending on the offset chosen) on paper even tho X and Y are set to 0.0.
The frame itself has the correct measurements.

Current approach/solution:
changing from layout print to a normal view-port print let’s me select ->Position->Centered= enabled thus disabling the (x0.0/y0.0) offset.
Changing back to Layout print keeps this(centered) setting active and the offset disabled.
Output now directly to the printer works perfectly.

However (there is always one, isn’t there?)
selecting Rhino PDF as output results in the ‘centered’ setting to kick in (still greyed out tho… but it’s a sneaky one… like his mate the center-osnap) and centering the frame in the document/PDF.

Solution here: Microsoft print to PDF (and maybe other PDF exports) produce the expected result.

Yes, 1.2 mm may not be much and most ppl may not even notice it on paper as a displacement but… this customer is a typical german DIN/ISO lover and if he lays this paper in a folder with correct Layouts and they do not align perfectly he may as well die of a heart attack.
On the other hand i do not want that for myself trying to figure out a way to prevent his imminent death. :sweat_smile:

Best regards

File with the frame for testing:
ISO7200.3dm (41.1 KB)

PS: Rhino is current.

Hello - thanks, I’ll take a look.

@4f233z - here is what this looks like here (the setup as the file opened was ‘extents’ in the View and Output area, I changed that to ‘Layout’):

Does that look correct?


Well, that’s indeed how it should look.
However, this is what i get:

My ‘position-> Offset From’ is not greyed out like yours and, as i stated above, can still be changed causing the issue.
changing to upper right:

it moves slightly to the lower left :man_shrugging:

Could there be any (general)Layout settings causing this?

@4f233z can you please expand the print dialog so that all settings are visible, and make a screen shot of that?



Vectorized or raster output changes nothing

@4f233z - if you are not printing with the layout, or some layout active, (i.e not Model space) can you please try that? Any better, or different?


Well, this is odd.
i opened the file on my work laptop: all fine.
saved it, opened it on my Desktop PC… no problem anymore.
Downloaded my own file from post 1 and still no problem.
Even the Rhino PDF export ignores the greyed out ‘centered’ setting now as it should.
So… no clue of what happened but it fixed ‘itself’.
Also can’t reproduce the error after a few tries.

Only difference that comes to mind is that i did a full PC/OS shutdown over night instead of a restart i did trying to fix the error.

Kinda feel like i wasted your time now, sorry for that and thanks for looking into it anyways!

Now have fun with the important stuff up ahead :tophat:


1 Like

Hi Afreez - thanks for the update… I’m glad it is fixed, because I was running out of ideas!


1 Like