_Print freezing up on Pen mode

Trying to use the _print command on this aerial view of my model. Every time I initiate the command it scales the line weights by 3.0 which i change back to 1.0 because they’re super thick. After choosing where to save the file, it always freezes. I’ve tried messing with print settings and the viewport settings over the past two days to no avail. Any help?

Hello - what is the print destination? Can you also run SystemInfo in Rhino and post the results here?


The print destination I’ve been using has been Rhino PDF.

Rhino 6 SR15 2019-6-13 (Rhino 6, 6.15.19164.21011, Git hash:master @ e41c99d36bb5000377057645e96b3ea6facf6171)
License type: Commercial, build 2019-06-13
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: GGLO118

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro K2000 (NVidia) Memory: 2GB, Driver date: 4-9-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 425.31

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-9-2019
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”
C:\Program Files\Enscape\Bin64\Enscape.Rhino6.Plugin.dll “Enscape.Rhino.Plugin” 2.5.19102.1302
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.15.19164.21011
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Your display driver is fairly new so it’s probably not the problem.

Are you specifying a file location for the PDF on your local computer? If not try that.

If that doesn’t work, try this:
In Rhino Options > Plug-ins, change the list filter to plugins that do not ship with Rhino.
Disable all of them and restart Rhino.
Then see if you can print.

We’re trying to narrow down the possible culprits.

Yes I’ve been specifying my project folder just like normal. I just went through and disabled all of the plug-ins I found in “Plug-ins that do not ship with Rhino” and still ended up freezing my computer.

Appreciate your help, thanks

If you start a new file, draw a box, set it up to print like the problem file, does it work or does it freeze too?
I’m trying to determine if the problem is unique to a file or a general problem on your computer.

So I gave it a shot in another file I’m currently working on and it worked but it did take awhile for what I thought to be some pretty simple geometry. My other model is quite a bit more complex.

Parking Model Ramps.pdf (1.3 MB)

I would recommend trying the SR16 release candidate. We have been working on an issue where display modes like this were using too much memory when generating prints.

So that ended up working and now I’m able to print although it still is taking longer than what I’ve been used to in the past. If you guys happen to find anymore information on the subject I’d love to hear more. Thanks for the help