Print colour isn't working on surfaces

Shaded mode-Reset to default
as you can see when i select print colour only the curves are set to black,I want the surfaces to be black(or any other colour) as well but cannot seem to get it to work.

Display colour

print Colour

Have you assigned colors to the objects directly?
They will only print the layer color if the Object color is not overriding it.

No,Colours are assigned through layers,
Display Colour=ByLayer

Post your example 3dm file please.
In a case like this, guessing is a waste of time.

1 Like

print colour fail.3dm (44.6 KB)

In the Layout, make the Detail active (double click in it), then in the Layer panel, change the Layout color for those two layers to Black.

Ahh brilliant,Thanks.

Is there a way to do it across all viewports?

I don’t think so. If I remember correctly, that “Layout color” setting makes it so the same object in different Layout Details can have different print colors.
It will take a bit of experimentation to sort out the deep specifics.
The description is probably in Help too.

Ok,Thanks very much for your time.