Preventing rhino from trimming in infinite z


I’ve got a problem that feels like it should have a simple solution. I am modeling a landscape based on meter contours that i have draped and created tighter contours from that i will later want to mill. I have edited the contours slightly manually afterwards to fit my preferences. Now I would like to extrude solids from my contours that aren’t closed. I tried to create surface planes to split all at once, but when i try to do so all of the contours split or trim the planes as if they are extruded infinitely in the z direction. How does one split or trim lines only in their actual place so that one line splits one surface and not all? If this is not possible how should I go about the problem without manually selecting one plane and one line at a time?bild


It appears that you may be encountering Apparent Intersections where a curve used for trimming or splitting does not need to be in contact with the object to be trimmed or split.

The Trim command has the ApparentIntersections option. ApparentIntersetons=No will result in objects only being trimmed which are in contact with the trimming tool. Trim | Rhino 3-D modeling

The Split command does not have an ApparentI ntersections option. To enable or disable Apparent Intersections for Split go to Options > Rhino Options > Modeling Aids > Object snaps and check or uncheck Use apparent intersections

A solid in Rhino is a closed surface or polysurface. It is not possible to create a solid by simply extruding an open curve.

Any line or curve used for trimming in Rhino cannot end in the interior of a surface. The curve must be either closed or extend to the edges of the surface. The Trim command has an option to automatically extend lines but not curves.

A surface in Rhino cannot be split with the split ending in the middle of the curve.

Thanks for the replies David!
I tried the apparent intersections set to No both within the trim-tool and from the options menu but I get the same result. Am I still doing something wrong?

Reply to your second comment: that is why I am trimming planar surfaces so that I later can extrude the resulting surfaces.

Hi Edward – can you post your file or a subset of it? or send to with a link back to this topic in your comments.

In case it helps - I made a script for another user - if your curves all end right on a perimeter, in plan, like this:

then it will make closed planar curves on both sides like so:

that you can then extrude to taste. (2.8 KB)

To use the Python script use RunPythonScript, or a macro:

_-RunPythonScript "Full path to py file inside double-quotes"