Preferences odd behavior

i have noticed that i can only make one or sometimes two changes on any of the settings. after that the next thing i try to make a change on doesnt have any effect. i need to close the pref window all together then reopen it to change the next item. colors for instance. i can open it up, change one color and if im lucky two. when i change the third nothing happens. close the window and reopen it then i can change the third. close it again and reopen then i can change the fourth and so on. so far i have seen this on the colors window and the display modes window. havent tried any others.

Strange. I cannot reproduce this behavior on my machine with 5.0.2 on OS X Yosemite 10.10.5. Can you please send along your Software Information? This is found in Rhinoceros > About Rhinoceros > More info… > Copy to clipboard) by pasting it here.

Anyone else having problems with making changes to Preferences?

hi dan,

here you go.

Software information

Software versions
Rhinoceros version: 5.0.2 (5A865)
IronPython version: 5.1.2015.131
Language: en (MacOS default)
OS X version: Version 10.11 (Build 15A282a)


Third party kernel extensions
com.3dconnexion.driver (10.2.3) B7F83C8F-1E8D-3DC6-85FF-21D6CA69827D
com.Logitech.Control Center.HID Driver (3.9.1) no UUID
com.Logitech.Unifying.HID Driver (1.3.1) no UUID

Hardware information

Computer hardware
Hardware model: iMac11,1
Processor: Intel Core i5 CPU 750 @ 2.67GHz
Memory: 12 GB
Architecture: Intel 64 bit

Video hardware
Graphics: ATI Radeon HD 4850 512 MB
Memory: 512 MB
Screen size: 2560 x 1440, 1920 x 1080
Displays: iMac (109dpi 1x), VE247 (92dpi 1x)

USB devices
EPSON: USB2.0 MFP(Hi-Speed)
UltiMachine ( RAMBo
Logitech: USB Receiver
Apple Inc.: iPhone
Apple: Card Reader
Apple Inc.: Bluetooth USB Host Controller
Apple Computer, Inc.: IR Receiver
Apple Inc.: Built-in iSight

Bluetooth devices
Apple: Apple Wireless Keyboard

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-10.0.37
Render version: 2.1
Shading language: 1.20
Maximum texture size: 8192 x 8192
Z-buffer depth: 24 bits
Maximum viewport size: 8192 x 8192

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 2x
Mip map filtering: None
Anisotropic filtering: None

Thanks. Investigating (MR-2320).

Is anyone else seeing this running on El Capitan?

I cannot duplicate this with Rhino for Mac 5.0.2 and OS X 10.11 (15A282b), which is the El Capitan GM release. Specifically, I opened the Preferences panel, selected Colors, and changed the Viewport background color repeatedly. I could see the background color change in the modeling window with each color change. I then repeatedly changed the Minor grid line color, again observing each color change.

Can you provide specific detailed instructions on how to repeat the problem you are seeing?

hi marlin and dan. i made a quick video showing this. this particular time it seemed to do it right off the bat. you’ll notice the first and second items i tried to do didnt work then the 3rd and 4th did and the 5th went back to not working again. weird. one other thing i noticed was when i started rhino and tried this before i made the video, everything seemed to work ok. i changed colors prob 10 times with no issues. what i found was that you choose the item and the color selector pops up. if you leave the color selector up and change all the items you want to without closing it out it seemed to work ok but if you do it like i did in the video where you close the color selector window after each item color change, that is when the problem seem to pop up. that could just be coincidence though. seems when that color selector window pops up its random if it will work or not.

not sure what the problem is but…

you’ll notice when the colors don’t update as expected, the color you’re trying to change isn’t selected (even though you are clicking on it and it’s popping up the picker)…

when the colors do work as expected, the color you’re trying to change is actually selected (as evidenced by the grey outline around the color you’ve chosen to edit in the preference pane).

the only way i can sort of duplicate what you’re seeing is if i try double-clicking the color in the pref pane… the first click selects the color and pops up the picker… the second click deselects the color but leaves the picker up.


jeff, it very well could be i am automatically double clicking the item. its so second nature to double click everything i am not sure what i was doing when i made the video. i can see when it doesnt work the item has a grey box around it for a split second. im just not sure if for some reason its not sticking or i am double clicking. seems like the color docker should only be up if something is selected or to choose a color there should be a radio button next to each item and an apply button in the color window. just seems too easy to make that mistake. i have been on a mac for 5-6 years but perhaps im just regressing back and the windows in me is kicking in…lol.

yeah, the color picker can float on its own and generally doesn’t auto-close.
you can even make a simple app that’s strictly the color picker with no other application open.

it’s good for situations where you may want to sample various colors from various photos etc… creating color palettes and what not… or when wanting to share colors between separate applications.