Possible bug?


When I move the vertex with REFLEX activated I get some weird new edges
With REFLEX OFF this does not happen
The Rhino file with this issue(REFLEX still ON) is attached

Is this a bug or am I doing some mistake ?


RatoSubD 004.3dm (451.1 KB)

I don’t know if we should call that is a bug

Mistake or not, You move point inside reflected geometry, that’s why it happens.
RH doesn’t punish it, theoretically it is led back as three side face (cut by reflected axis )

Edit, theoretically it is led back as three side face
RH removes PT inside reflected side, You can see it, press F10

Thank you for the reply, so you in your opinion this is normal ?

for now yes, this is expected behavior. Is it right? You and the rest of our users will tell us, and we’ll adjust as needed.

thank you for the reply Kyle.

What is strange to me also is that, after moving that vertex with REFLEX ON, those new edges pointed by the black arrows appear in SMOOTH mode, but in FLAT mode they are not present (the smooth and flat mode not consistent with each other it looks)

The issue was that your edgeloop along the reflection plane is not perfectly planar. Remove reflect and and add it again to fix the extra edges getting added when you move a vert along the X axis. See the video attached where I show that there is a scale handle in Y on the Gumball when selecting this edgeloop and the GB is set to by object. If it was planar, there wouldn’t be a scale handle on the GB. Compare this to no scale handle on the GB after removing and adding Reflect again. Note that I used Shift held down when defining the reflect plane from the vert to make sure it was straight with the X axis. Then when you edit a vert along the reflect plane in the X direction, you won’t be moving at a slight angle, this was causing the extra edges.

Hi, Brian

I know this issue well and it causes me a lot of troubles. Succede that in fast transformation with the gumball I move verticies/edges away from the reflect plane by minimal distance without notice that in low poly view and it is annoying to correct this mistake many times afret several modeling steps.

Is there a way to lock verticies/edges on reflect plane to avoid this issue??

Many thanks Brian, now I got it ! :grinning:

You can’t keep edges and verts along the reflection plane but you can use the Distance snap style in Reflect and set a value to account for edits that leave the plane. This feature is sometimes called clipping in other apps that have symmetry or mirror modifiers. It will auto merge verts within a distance but it can also make ngons when you don’t want them. This might help but I prefer to have an edgeloop along the reflect plane and only edit it in plane using the GB. It’s helpful to use the X or Y reflection plane options so you know you are aligned to these axis and then have the GB set to Cplane/World.

not really happy with this, can you please add an “option” to keep or not to keep?
in my mind if I selected some verts as reflection plane, moving one of those is like to change the reflection plane.
(so sorry, my english is not good enough to explain better)