Possible bug into Intersection.CurveSurface() method?

I think I might have encountered a bug in the Intersection.CurveSurface Method (Curve, Interval, Surface, Double, Double) method used with the subdomain parameter.

In a specific situation (see attached grasshopper definition), the method returns a valid intersection point between a sphere and a curve. However, the point is not in the specified subdomain and the method should not return any intersection object (I think). Conversely, the method returns a valid intersection point (XYZ coords) but with a wrong curve parameter, which is in fact the lower bound of the specified subdomain.

curve-sphere.gh (11.6 KB)


Anybody can confirm this is a bug ?
I’ve made a dedicated gh definition to track down this issue …


Hi @lionpeloux,

The attached seems to work. Does this help?

test_csx.gh (9.4 KB)

– Dale

Hi Dale,

Did you look at my debug MWE ?
I’ve plugged your example into my data and I still get the same error …

Please, look at the updated MWE attached to this post and let me know what is your opinion.

curve-sphere.gh (16.0 KB)