Possible bug in zooming?

Using a Mac, I have experienced several times, where the thing I am working on just zooms off away to infinity or somewhere in the pane I’m working in! It is visible in the others, and ZEA just zooms in the others, but nothing in the missing one. I then need to export and reimport into a new page to get it to reappear.

Is it just me?



I don’t have an answer to your question, but seeing your multitude of dense surface patches I think it is time to watch @sgreenawalt ’s series on YouTube about primary surfacing. In particular related to your design: https://youtu.be/pcMIvkpxk0E

1 Like

Hi -

It’s hard to say from just a picture - can you post the file? It looks like the perspective viewport is also zoomed in on the object but the object is not visible. What happens if you put the perspective viewport in the Wireframe display mode?

At any rate, please run the Rhino SystemInfo command and copy-paste the result here.

Sorry, re-imported it into a new page to reset it. It has happened in other display modes too, this just happened to be in the perspective one. No change of display makes any difference.

I’ll post if it happens again.


OK, it just did it again. This is the systeminfo fileUntitled.txt (5.2 KB)

Hello - my guess of the moment is that there may be some object way off in space - fi you window select all the expected items in the view and then run Invert - does anything get selected?


Sorry, nothing happens. I have to re-import it into a new template to get it back. :rage:

Hi Gordon - can you post here, or send the file to tech@mcneel.com, with a link back here in your comments?


Carla replied -

  1. Download the latest service release from here.

  2. Reset your Rhino for Mac preferences

  • Quit Rhino completely.
  • In the Finder , hold down the Option key, and select Library in the Go menu.
  • Open the Preferences folder.
  • Find the com.mcneel.rhinoceros.plist file. Select Duplicate in the right-click context menu to make a copy. The copy will be named com.mcneel.rhinoceros copy.plist . You can save that plist file elsewhere and then delete the original plist file in the library.
  • Restart Rhino, this will generate a new preferences/plist file in the library.

Hope this works!


Sorry, hasn’t worked, it just did it again :rage:

Hi Gordon - did you send us a file to look at?


This is one of them.

Drifter (6.2 MB)

Tx G

Hi Gordon - is there a particular action or command(s) that you can associate with this zoomy thing? All views have gigantic coordinates.

Check for the Camera Z Location


Other than I’m just zooming in with the usual Mac 2 finger touchpad control and it suddenly goes to infinity or wherever.


Ah. Ok, thanks, I’ll mess with that.



What is pointing @Neomega-Resin concerning the touchpad is correct and is not a new issue.

When executing various commands ie : Sweep, there is something strange happening when trying to rotate the view to evaluate the computation.

Screenshot 2021-03-12 at 07.38.19

The normal behaviour is : Content tracks finger movements
What happen is this

It is simply impossible to rotate the view during the operation.
In the other hand, the Zoom IN/OUT behaviour is working as expected.

Screenshot 2021-03-12 at 07.42.28

This is a problem that seems to occur only when the dialog box of the running command is active.
Something annoying we deal with for a while.

Rodolfo Santos.

1 Like