Positioning an object in 2D view

Hi,

Here is a recurring problem that I often have in Rhino that does not make sense to me.
The PCB map was previously well positioned at the X, Y position. (“Bottom” window in 2D)

Now, I have to put it correctly on Z, So I change my mind and I go on “Behind”: (2D window)

I click on the PCB and I bring it to contact on a small column (in red), and there the software is superb, there is magnetic attraction and it sticks all alone .

It’s really an interesting Super function, except that all the X, Y positioning has been reburned too.
The whole circuit has advanced forward.

For me it is not logical, we are on a view “behind” which is a 2D view, so all the movement that we do in this window should be in 2D and not in 3D.
Here I was just climbing up the PCB , so it should have gone up, without moving forward in Y.
Can you explain to me how we can do?

(sorry for my English)
Best regards,
Jean-pierre

i am not sure i understand fully, but i try. if you turn on osnaps project each reference point to move from and to will be projected to the construction plane meaning that the object will stay positioned in the z axis moving your objects only in x and y.

another method would be to choose the move from position in the move command then when prompted to choose the destination point you type .xy which will let you pick a position in xy then target the starting position again which will constrain it additionally in z axis again. for this to work you of course should have point activated in osnaps.

another method which i mostly use is to switch on ortho with shift and lock the direction with tab and target the end position which you do twice to position the object entirely.

Thank you for your reply.
I do not quite understand the first method.

On the other hand, the second method seems more understandable to me.
But need you to give me more details so that I understand and that I can do it again on my side.
how twice?
on the image below, I have selected “Ortho”,


but the result is still bad, it has shifted also Y.

link below to download my simplified file

the only thing you need to know for the first method is that if you use project in your snaps that it will not move it in the perpendicular axis from your view, only along the axis displayed. meaning in top view it will not change the z axis, in front view it will not change the y axis etc. try that first it might be the easiest. this snaps mode is also good if you want to be sure to draw in plane. even though you lock to other objects. just dont switch views, you can have 4 views open and you will see what it does with the chosen points. it projects the selection to the cplane, but stay in the viewport you have started with.

to move as i described in the third method orthogonally, you simply press shift when in the move command, it will lock it to 90° angles. then press tab which will constrain the direction. then just iterate to the position with that method first along x then along z for the front view for example.

This “project” mode is one of the most confusing things when people start learning Rhino. In my classes even though I spend quite some time explaining this feature it is still leading to lots of problems during modeling.
@pascal maybe you can make a wish item for v7 that this feature gets some attention. It should imo be much more visible (maybe a mark in the corner of the viewport or something like that) wether or not this mode is active. @dan I also want to emphasize that on smaller MacBooks this feature is most of the times invisible and you have to scroll in the osnap to get it visible.

1 Like

i would also not mind having a project option in move and draw commands. or lets call it axis constraints to astray from the confusion :smiley:

I’m sorry, but I can not understand.
For me, this is not logical, we are on a 2D view in the Z direction, so we should not be able, by making a Z translation upwards (in my example), to also make a translation in the direction Y! And that’s what happens. YES, I love your software.
Can we automatically block this displacement Y in version 7? (This is valid for all 2D windows, always block the displacement in the third dimension).

If anyone can make me a little tutorial to download?
But hey, if it bothers you, I will do without this function that would be very easy to use.

Hi Gijs -

in V6 onward, the snaps show ‘Projected’ when Project is on.

image

I guess that is not enough?

-Pascal

I have version 6,
but the object I move up (Z direction) in a 2D view (behind), also moves in the Y direction, while it was before already well positioned in this direction!

It’s not easy to solve this nicely, but I think it needs something else. Thing is that when project is off, you don’t see it’s off and this is easily overlooked.
Sometimes the difference between a projected and not projected point can be small so one has to be very careful (remembering to check project) before starting a move/copy
This is one of the reasons btw that I prefer moving things with Gumball instead.
What @artec-france says in fact makes a lot of sense, in a 2d view the view Z axis should be locked. Maybe a option toggle in Rhino settings?
Just thinking out loud I am not sure if there are any drawbacks doing this.

YES, that’s exactly my problem.
It would be necessary to lock the third dimension ONLY when one is in the 3 views which are in 2D (face, right, top)
and nothing to block in 3d view (perspective), that would seem logical to me!

if you can do that for version 7, then, for sure, I will buy it, because it will be much more convenient to stick the objects “magnetically” against each other.
Because the principle is super simple to use. Just push the mouse in 2D the object against another, and they stick together, we let go and it’s over, it’s perfect

Not sure if you got this from @encephalon answers, but you can work this way. All you have to do is enable “project” option in your osnap toolbar.
Or use Gumbal.

Hi Gijs - a setting in Options > ModelingAids page > Object snaps for ‘Always project in plan views’…?

That seems like it could be useful.

-Pascal

2 Likes

Yes that. I can’t really think of a situation where I wouldn’t use it.

I tried to suggest a couple of years ago that we should have a new project-“button” similar to grid snap, ortho, planar, smart track, gumball and history in the same row. I still think it would be a good idea. We already have six buttons there - a seventh wouldn’t hurt.
@pascal, @dan

Philip

2 Likes

I’d like some “official” feedback on this. Is this difficult to do or don’t you just like the idea of an extra button?
@pascal, @dan

Philip

Hi Philip - thanks for the nudge. My preference by far is to put this in

Options > ModelingAids page > Object snaps for ‘Always project in plan views’

and not on the top level UI in the viewport - that seems like overkill (to me) in that it is not a setting one would likely want to change on the fly very often, and could lead to confusion if clicked by mistake, it seems to me. But I will add a wish for some version of this.

https://mcneel.myjetbrains.com/youtrack/issue/RH-54162

thanks,

-Pascal

Hi Pascal

That could be a good idea also.

I like to normally have ‘project’ on - and I use it also in the perspective viewport - but I turn it on and off on the fly quite often during a session, so I really would like to have the additional ‘project’ button.

One button that I always have on and never change is ‘planar’, however - so why don’t we change ‘planar’ to ‘project.’ :wink: Planar seems to be there only for historical reasons and not a setting you would need to alter on the fly - at least this is how I see it.

Philip