Polysurface and problem for 3D Printing because of a bug


#1

Hi!

I had this surface i create.
I tried, in order to give a thickness of 1 mm, to do the “offset surface” command.
And i don’t know why, each time i try it, Rhino stops with a bug, with a message in my cmputer that writes “Memory of Windows is not enough. Rhino will stop when you accept”. You should switch on your computer after Rhino Stops".
I don’t think it’s because my computer is not enough strong, because it’s a portative msi brand, with core i7, , intel R, Core TM, 4720hq, cpu 2.60 2.60 ghz, ram installée 8go, se 64 bits, processeur x64.
I’m not a geek, but i ask me if at a moment, when rhino stopped, that is was written Rhino 32 bits, but i’m not sure…
I will give in this post, step by step how i did.
Its there another solution?
Thanks a lot! :slight_smile:


#2

This is the message that says that windows is not strong enough…


(John Brock) #3

Since you want to STL print it, I’d try a different approach.
Mesh the polysurface first. Hide the polysurface to get it out of view.
Then offset the mesh with the solid command line option to make the object you want to print.


#4

In order to know if i had much more “maillages”, i converted my file in .stl, and did an analisis to know the number of polygons.
It was written that it has 214 706 polygons.
I thinks it’s not much, no?
First i wanted to print an object that had 20 cm with 5 cm high.
When i saw the bug, i thought it was bigger, so, i reduced the scale, and now, the object is only 6 cm with 3cm.


#5

In order to try another solution, i created a rectangular volume, and i thought that with doing “cap” to make full the volume of the project, i could scale a little bit large the volume, and do 2 boolean substraction, in order to have the resultant volume.
I tried, first, only with a rectangular volum, that i wanted to be substracted, to do a boolean substraction. First, the rectangular, and second, the project, that i want it substracts the rectangular.
Like this:


#6

But, after i do the substraction, i don’t know why, only the volum of the project stays, without substraction, and the rectangular volume disappears…
Do you have a solution?
Thanks so much! :slight_smile:


(Brian James) #7

I think you either are choosing to ‘delete input’ in the command line options for the Boolean or one of the objects is not closed.

Regarding your original error message, I haven’t translated it but I think it says you don’t have enough memory available. How much RAM is in your system and is this the 64 bit version of Rhino 5? That may be the issue.


#8

Hi Brian!
Thanks so much!
I will try this!
Well… my system windows said that i have 8 go of RAM, is it enough?
How can i see if my rhino is in 64 bits?
I hope yes, because i bought rhino in Paris on sepember 2016…

But, yes i have a doubt about this, because i m not sure, but at a moment of the bug, i think maybe it was written “rhino 32 bits”.
If it is it, how can i have the 64 bits? Because i think in this september 2016, it should be good, no?
Thanks a lot!