PolylineOnMesh error - the line disappears

Hi all,

For my work I have 3D obj models of coral reefs made in Agisoft and I use the PolylineOnMesh tool to cut out individual corals. This used to work well a year ago (https://1drv.ms/v/s!AvOC3oq4Zscw3ki6MpSU2rBKYfF0) but since this fall we are having troubles. In many of the models when I trace the coral around with the PolylineOnMesh and then click on the beginning point to connect the line to a circle, the line disappears completely (https://1drv.ms/v/s!AvOC3oq4Zscw3kf1yFi15CQZ38u-). Can someone help me figure out how I can get this to work again?

Thank you


Hi Franziska - instead of clicking the last point, what happens if you use the Close command line option?

And, if you hide the mesh completely, is the polyline there or is it not created at all?

Does your display mode have ‘Curves’ set to show? (Display panel)


Curves are set to show and the polyline doesnt show up if I hide the mesh.

Sometimes a line doesnt work and the next time I try it does. Simple lines with a few nodes generally work but with more complex ones (many nods) it doesnt always work.
When I make lines that arent supposed to close I have the same problem.

Hi Franziska - Please run the SystemInfo command in Rhino and copy/paste the results here.


Rhino 6 SR22 2020-1-28 (Rhino 6, 6.22.20028.13281, Git hash:master @ 379871ece695dc096e83826f08b429db8ca2e7f5)
License type: Educational, build 2020-01-28
License details: Cloud Zoo. In use by: felmer ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: LAPTOP-JNPF4M7I

Hybrid graphics system.
Primary display: Intel(R) HD Graphics 630 (Intel) Memory: 1GB, Driver date: 7-24-2017 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 1050 (NVidia) Memory: 4GB, Driver date: 10-30-2017 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 388.16

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-30-2017
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.22.20028.13281
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi Franziska -

In terms of GPUs, those drivers are ancient. Please open the Notifications panel in Rhino to find links to updated drivers.

I updated the driver and it seems as if it is fixed now. :slight_smile: