Pollination plugin expired

Hello, I want to install pollination plugin but I receive this error that the version of plugin is expired. However it is the latest one. can you help me?

Hi - please visit the Pollination forum here: https://discourse.pollination.cloud/
-wim