Point within BREP is reading all false

I am trying to organize the centroids of the panels to either be within the BREP or outside of it. However, it comes up with a reading of all false which I didn’t think was true. Attached is my file. Any help would be appreciated. Thanks

New Facade Definition.gh (13.2 KB)

you need to internalize your data (right click on initial geometry containers)

I believe Point in Brep is looking for a closed Brep, not a surface.

Thanks. I am new to this. I have looked online for the answer into how to change my single surface into a closed BREP but I could not figure it out.

Also, I am unsure of what internalizing data means. I tried right clicking on my surface (BREP) and clicking “internalize data” and it unplugged a connection from my previous component. Is this reaction typical?


Your definition will reference some Rhino geometry no doubt. Right click on any components which reference Rhino geometry and click ‘internalise data’ and save the GH file. This will cut the link between RH & GH so that your GH file can stand alone without needing a RH file. This is the simplest way to share scripts.

Ok, thank you. I have done that now.

Do you have any suggestions regarding changing my single surface into a BREP?

For Help Definition.gh (19.7 KB)


You can extrude it:

extrude_2020May26a.gh (22.5 KB)

Ok, thank you! I did try that before as I understand a brep to be a collection of surfaces.

However, I tried with the components in the place that you put them and it is still reading all false.

For Help Definition_2.gh (22.0 KB)

Is there any other tips you could give me? I noticed that when I click on the “Point in BREP” component nothing turns to green, which I find odd.


Point in Brep outputs a true false list, you then use dispatch to get the in or out points, hence no visible output.

For Help Definition_2.gh (21.3 KB)

Since your surface is flat, you might also consider point in curve.
Note that if you want to include points that are on the edge, you will need to set the “>” component to “>=”.

Thank you!

That was the answer I was looking for.