Point lights not showing when I turn off the ground plane

Dumb question, when I turn off the ground plane, point lights stop showing up on rendering. I dont want the ground plane, but I do want the lights to show on the object. Simple setting issue?

Is this with Rhino 8 and Rhino Render or Raytraced? If you can please share a simple 3dm file showing the issue.

edit: as far as I can tell point lights work just fine without groundplane at least in Rhino 8



there are (4) images raytrace with and raytrace without the ground plane, render with and render without the ground plane.

The images with the ground plane show the side of the box with the light on them, the ones without the ground plane don’t. All of them show the sun reflecting off the top of the box

Please run the Rhino command _SystemInfo and post the result in a reply.

Also, can you share that model here?

Rhino 8 SR6 2024-4-10 (Rhino 8, 8.6.24101.05001, Git hash:master @ 32c244aa711e0034e75bec2e87d093c764820b96)
License type: Commercial, build 2024-04-10
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 8GB)
.NET 7.0.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: Radeon RX 580 Series (AMD) Memory: 8GB, Driver date: 7-20-2023 (M-D-Y). OpenGL Ver: 4.6.0 Compatibility Profile Context 23.7.2.230718
> Accelerated graphics device with 7 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 7-20-2023
Driver Version: 31.0.21023.2010
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8170 MB

Rhino plugins that do not ship with Rhino
C:\Program Files\SimLab\Plugins\SimLab PDF From Rhino\SimLabPDFExporter.rhp “SimLab PDF Exporter”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

sample for rhino240416b.3dm (14.2 MB)

This is Rhino 8, Rhino Render and Raytrace



screen captures with render window open, when I change the settings I go to wire frame and back to raytrace to ‘reset’ the raytrace.

What you see is the groundplane reflection in your metal material. This is something that is on my list still to potentially tweak, but right now the shadows-only ground plane is hidden only from camera rays, not from indirect rays.

edit:

When the groundplane is turned off you essentially get the environment in the reflection that is set to the custom environment for reflection.

endedit

Logged as RH-75603 Shadows-only groundplane shows in reflection.

The issue is otherwise not open for public due to some files in there. But I have link to this topic.

Simple fix?

No, and it is not currently on my 8.x list, but rather for 9.x. Depending how I get to my other already scheduled tasks it may get bumped to 8.x.

Of course, you could set a custom environment that is completely white in the custom reflection environment. Just set one with just white solid color. Maybe that gives what you want.

Im trying to get a totally transparent background when rendered, and as a PNG file. I can turn off shadows but the looses some of the detail in the part. other suggestions? (and thanks for the help)

Ah, so if you only want to keep your box and anything outside it thrown away then render with groundplane on, but in Rendering panel under Render Channels section select Custom and check Material Ids

image

Then render your model with _Render and save your RBGA out as PNG, but then also via the render window View menu select the Material IDs channel. With that channel active hit the save icon and choose EXR as your format. Give a name to your file, and say no to the dialog that asks you if you want to save the RGBA channel instead.

In Blender then you can composite this so that you end up with an image that has proper alpha. Let me record something for you.

@payton, here is one way to get you to a result with just your object and the groundplane alpha-ed out

The resulting image

Final render saved out:

thanks!!