Point In Curve Bug

bug
unhandled

#1

Point in Curve Bug.gh (3.7 KB)
Point in Curve Bug.3dm (39.3 KB)

I just discovered a weird bug where a point is not registering as “inside” a curve. If the point is moved at all, it registers as “inside”. Already tried projecting everything to a common plane, checking for closed curves, etc.

While I’ve never found/noticed this before, it happened in 4 cases on a single scope of a single project. Not an issue this time, but could be in other cases if Point In Curve component is found to be unreliable.

Am I missing something? Or could this be a back-end problem?

Tried both in Rhino 5.0/gh0.9.0076 and Rhino 6.0/gh1.0.0004

Thanks


#2

Your boundary curve is not closed, but it is named closed in gh because the tolerance of the document is too small for the scale of the model. Change the Rhino document units to meters.


#3

Thank you, Dani. The fix that you suggested sounds reasonable, because it increases the document tolerance by default.
However, with some experimentation, I have found that any change to the tolerance, up or down, fixes this particular instance. This suggests to me that the fix is incidental, possibly a difference in rounding somewhere.
In every case, Rhino and Grasshopper report the curve as closed, but only sometimes report the point as “inside”. Still sounds like a bug to me.

Also, can you explain more about model size vs. document tolerance?
If I am working on a airplane/rocket that is large, but requires a tolerance of .0001mm, it seems like that should be my choice. As I understand it, smaller tolerances generate larger files (more precision = more math?) What, in your understanding, determines when a model is too large for the document tolerance?

Thanks!