Point in Brep causes rhino to shut down

Hi all,

I’m trying to create tendons for post tensioning concrete. In order to do this I’m using Point in Brep a few times.

When opening the file it sometimes just immediatly shuts down.
I’ve tried to single out the problem by disabling large parts of the script and found that Point in Brep is causing the shut down. This is however quite random. Sometimes it works, sometimes it shuts down without warning.

Does anyone know how to resolve this, or what I am doing wrong?

All help is welcome!

I’ve included the simplified script (with internalised data) with ‘point in brep’ disabled.

problem point in brep.gh (60.2 KB)

Kind regards
Pieter Bieghs

Crashing should never be the user’s fault, so you can’t be doing anything wrong by definition.

I think this is related to the parallel computing option on the Point In Brep component. Try disabling that. I’ll do some tests here to see if I can repeat.

I do recall something being fixed in this area recently, what version of Rhino are you running?

My current version of Rhino:
Version 6 SR13
(6.13.19058.371, 2/27/2019)

I tried disabling parallel computing and it didn’t crash anymore, so it’s probably related to that.

Thank you for the fast response!

This report claims it has been fixed in R6.14

You can test whether or not your installed version has the fix by running the GetIssueState command with the code RH-51201.

I’ve installed R6.15 and it works perfectly, thank you!