PlugInManager lost

Hi,
I use a lot Rhino to developp PlugIns. With the version 5 and 6 off Rhino it was possible to load plugins via the PlugInManager. With the version 7 I simply don’t have the PlugInManager. I go to :Tools->Options
and… nothing do you have any Idea how it is possible?

Hi Markus -
When you type Options on the command line, does the dialog box appear?
Also, please run the Rhino SystemInfo command and copy-paste here.
-wim

Hi Wim,
thank you a lot for your answer. The option’s dialog box appear.
Here I provide you the full Rhino SystemInfo
Rhino 7 SR9 2021-8-10 (Rhino 7, 7.9.21222.15001, Git hash:master @ 190335c3fb65efe86c302714a8959a7dadfe667b)
License type: Pack école Revente interdite, build 2021-08-10
License details: Cloud Zoo

Windows 10.0.18363 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) HD Graphics 630 (Intel) Memory: 1GB, Driver date: 4-7-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro M1200 (NVidia) Memory: 4GB, Driver date: 7-3-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 431.40
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

Secondary graphics devices.
Citrix Indirect Display Adapter (Citrix Systems Inc.) Memory: 0MB, Driver date: 1-23-2019 (M-D-Y).
> External USB display device with 8 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-3-2019
Driver Version: 26.21.14.3140
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi Markus -

And, I suppose, there’s a Plug-Ins section on the left side? What happens when you click on that?

Apart from that:

I would think that this is the most likely culprit for any issues that you are experiencing. Is there any way that you can disable that?

The current final version is SR 10 but the SR 11 release candidate is also available.

These drivers probably could use an update.

-wim

The plugin manager user interface is implemented in the commands plugin which somehow must have gotten disabled on your system. Try dragging the commands.rhp from your installed rhino plugins directory and drop it onto rhino.

It wooorks
I don’t know why but updating the software worked. Thank you a lot