Plugin Manger not working in 11/14 BETA

I get nothing in the window when I start the pluginmanager command. See the attached screen shot. You can see the Peters Tools plugin icons at the bottom of the screen. They loaded but they don’t work and I can’t access the plugins manager.


1 Like

@john, @curtisw, @Trav didn’t we fix this bug recently? It looks familiar

@dmoyes would you be able to share your plug-in with me so that I can see what is causing the issue?

Hi @dmoyes,

Is this where you got “Peter’s Tools?”

– Dale


Here you go. As I said, this worked fine in the previous beta version from last week, as did the PlugInManager.

PetersTools.rhp (137.5 KB)
PetersTools.rui (269.4 KB)

@dmoyes unfortunately neither Dale or myself are able to repeat this issue with the Beta. Do you happen to have any other non-McNeel plug-ins loaded?

You may also want to run the SystemInfo command and paste the results into a reply.

– Dale

If I could see the pluginmanager I would check;). Maybe panelling tools and section tools.

Have the same issue. Open the plugin manager. Nothing displays. Select an other item in the tree on the left and select back the plugin manager. Works for me.


I was able to reproduce in a build from the 14th, but with a build from yesterday I am no longer seeing empty Plug-ins page. Let us know if next weeks BETA works better when you get it.

1 Like

FWIW, I am also seeing this with the Toolbars section in the current public build, clicking on the “Size and Styles” section then back to toolbars fixes it. Hopefully this week’s fix will also apply here… --Mitch

I think so, -OptionsPage z gives directly the Size and Styles page for me in the latest build I am testing.

Looks like it, yes.
My DocumentProperties went straight into the Render settings and that page also came up blank with the 14th release whereas with the current (6.0.17320.8481, 11/16/2017) release, this is fixed.

Rhino 6 SR0 2017-11-14 (Rhino WIP, 6.0.17318.8561, Git hash:master @ d5a07f941ad16bc8f7c4006efb6db93c687d1f52)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

Intel® HD Graphics 520 (OpenGL ver:4.4.0 - Build

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.4
Shading Language: 4.40 - Build
Driver Date: 7-6-2016
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino WIP\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino WIP\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino WIP\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2017.11.15.520\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino WIP\Plug-ins\CyclesForRhino.rhp “Cycles for Rhino”
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino WIP\Plug-ins\Calc.rhp “Calc”

That worked for me as well and I was then able to enable the PetersTools plugin. All seems to be working now.

1 Like

Just installed the latest Beta. Works fine now. Thanks for the fix.


1 Like