Plugin installation when there is ' '(space char) in project path

Hi there,
I am having some problem with my very first rhino plugin (C#) created on Visual Studio. I created two different projects for test this. One of my projects on inside of =>
U:\Gartner Tools\ProjectName
U disk is a disk on server. It’s not a local disk. And second folder as you see named “Gartner Tools”. When I run debug i have this error:
image
But when I save to project in C disk and don’t let any space in the path it works. What could be the problem?

How are you loading your plug-in? Loading plug-ins from paths with spaces in works just fine.

If you are trying to automatically load it through code then make sure you enclose your path in double quotes, "U:\Gartner Tools\ProjectName"

I did not edit anything on launchSettings.json. I check debug configuration it was like this:

{
  "profiles": {
    "GartnerToolsForRhino": {
      "commandName": "Executable",
      "executablePath": "C:\\Program Files\\Rhino 8\\System\\Rhino.exe",
      "commandLineArgs": "$(TargetPath)"
    }
  }
}

As far as I understand “$(TargetPath)” is the path. I tried it like this but result was the same:

  "commandLineArgs": "$\"(TargetPath)\""

I did not configure anything. I am just clicking the debug button on visual studio

Instead of defining it on the command-line I would just drag and drop from the build location on Rhino - that is how I do it.

1 Like

Well yeah it works now. But my plug-in is kinda have to be like a add-on. I want to create a tab and put my buttons on it. Also design some panels for my buttons. So if this plug-in installed on a computer it has to be automatically implemented when anyone opens Rhino. I am asking this for confirmation (as a newbie). Am I at correct path? To develop something like this it has to be Rhino 3d plugin right?

Installation would probably go through Yak and the package manager, that will take care of spaces in paths as well.

Make sure you check out Rhino - Package Manager Guides

1 Like

Then from now on I don’t need to worry about spaces in paths, so this solves my problem anyway :slight_smile:
Thanks a lot!

1 Like