Pls seem to have vaporized

Dear all,

After a long day of converting solids to dxf, these files all seem to have vaporized…

They are not hidden. Some parts i did still see after finishing my work, and now they are gone too.

The bending lines are there still (were in their own layer) but the other layers where i put the dxf files seem to be empty.

This was already not a great day, because of the extra work the cnc company asked me to do becaise their machine couldnt read some of the rhino files. This is why they asked for dxf.

But now im kinda lost and getting frustrated.

Any advise? Your help is appreciated!

Kind regards,

Objects visible in the original Rhino file but not in the .dxf file?

Some types of objects may not be able to exported in a .dxf file. Someone with more knowledge than me will not to respond.

Objects vanished in the original Rhino file?

If the Rhino file is still open:

SaveAs with a new name.

Undo until the objects appear or there is nothing to Undo.

If the objects are still not visible try the steps below.

If the Rhino file is not open then open the file.

Select all layers and sublayers. Turn all on.

Unhide in case anything is hidden.

Change the display mode. Some objects may not appear in certain display modes.

Also there are multiple options for exporting to .dxf files. These options may affect what is exported.

Thanks for your quick responses!

Its before exporting that they have vanished, and i did try all the steps you mentioned. No joy…

Are you using Windows or Mac?

If Windows go to the directory where the Rhino file is saved and search for files of type .3dmbak. There may be a backup file which has the data.

Thanks but unfortunately that backup has got the same error…

Strange thing is that not all parts have vanished.

And even stranger, just before i noticed what happened i moved a large part. Which is vanished now too :man_shrugging:t3:

Open the fille. Unhide to ensure nothing is hidden. Turn on all layers and sublayers.

Ctrl-Alt-E or Zoom > Extents The view will zoom in/out and pan so that all objects are on the screen. It is possible to move objects a long distance away by mistake. This will help find those objects. It is possible that if the object is fare enough away it may not be visible.

How are you “converting” to DXF? DXF files can’t be stored on a layer. So I assume you are doing something to the “solids”, putting the result on a layer and then exporting them from there? If you detail your procedure, maybe someone can spot the problem.

The shop has problems with the contours of folded solid parts.

So i explode the solids back to a surface, then unrollsrf, then silhouette and add the folding lines


Adter this id export it as dxf

Are you able to post a small example of a file where elements have vanished?

Have you tried rebooting your PC and reopening one of the problem files?

dxf forum.3dm (285.5 KB)

These are some of the layers that i put the curves in to export to dxf.

Btw i sure now something funny is going on, because the layer console had the sides visible before and now they are gone too

And indeed, i did try a reboot.

No joy unfortunately. Thanks though

OK, there are 96 objects on the layers you sent. That tallies with selecting the visible items.

If you open the original file from which you copied these layers and run the Audit command what results do you get?

audit.txt (919 Bytes)

So here we see that you have 219 deleted objects and 53 block definition objects.

Have a look in the Undo Multiple window (but don’t undo anything yet!) and see if there are recent undo commands that might have resulted in some of these. If you think that you have something to recover, make a copy of your file and open that in Rhino, run the undo steps until something reappears and then export that something (as a Rhino model) before doing more undo’s, in case they remove the recovered item again. If you do get useful stuff back then import it into the original model.

Next, open the Block Manager and check the count for each block listed. If you have blocks with a zero count look at the properties and preview to see if they look like missing pieces. Use Insert Block Instance to reinstate any you want.

Let us know if any of the tedium pays off…

Sadly all those undos were “change visibility”

And none of the blocks had a total count of zero…

Im 100% sure though that when i noticed parts were missing, the curves voor the sides of the console were there though


It might be that McNeel support have a way of undeleting the 219 deleted objects to see if any are your missing bits. Or Mitch might have a tool in his extensive array of code snippets. @pascal, @Gijs, @Helvetosaur? [Edit: wrote a script that does this, see later post]

In the meantime, you could check the Recycle Bin for older autosave backups.