Please help

Hi,

I’m new to rhino and have a problem. I joined 2 open polysurfaces together (in the OBJECT-layer) and the command line says it created 1 close polysurface, but when i’m in rendered view it doesn’t look like a normal close polysurface, I can see the second surface through the first surface. Furtheremore, I’m now trying to cut the closed polysurface from the OBJECT-layer by using Wire cut. The cutting curve is the closed polyline in the ref 2-layer. When I try this nothing happens. I believe this might be, because there’s something strange going on with the closed polysurface.

R0037_temp.3dm (962.2 KB)

Greetings,

Steven

Hoi Steven -
If you explode that object, select one part of it, and look at it in the Front view, you will see that the one half that you have selected crosses the Y-axis. The same for the other half. When joining these, the outside of that object at the top becomes the inside of that object at the bottom - the object self-intersects.
Rhino has no way of telling what is in and what is out and all kinds of strange things will happen.
-wim

1 Like

I noticed the same issue. I exploded your model, extruded the wire and splitted the ‘ring’. I noticed it is intersecting at the bottom so i left that part intact.


R0037_temp_return.3dm (1.1 MB)

Oh yes, I see what you mean. Thank you. It isn’t supposed to intersect the Y-axis.

I tried to explode the OBJECT and cut it with a line on the Y-axis, but this doesn’t seem to work. How can I cut the object with the Y-axis?

I’m assuming that you’ll want some material on the bottom side of the ring as well and, so, cutting on the Y-axis won’t get you much further. As it is, the intersection between a plane and one of the ring surfaces is a mess and your better option is to create a correct surface from scratch.
-wim

It’s ok if there’s nothing on the bottom, I’m making a cutter for a ring. I got the OBJECT from offsetting the surfaces of the ring, to get an equal thickness after I cut the ring with it.

In that case, you could probably trim the surface with a horizontal plane?
-wim

I’ve tried cutting it with a line, with a box and with a surface and with an extruded rectangle but none of these work.

I see that you are running an older (and illegally cracked) version of Rhino 7 but a horizontal surface somewhat above the position where it crosses the axis seems to work fine here:

If all else fails, you can turn on the points of surfaces and simply delete (or move) those that you don’t need.
-wim

Yes, that’s true. I’m using Rhino right now at home for educational purposes to make non-commercial exercises. I’ll have a legal version later on at work.

I’m looking to cut it by a plane formed by the z and x-axis.

Yes, that doesn’t work. The surface doesn’t only cross the axis, it also wraps around itself.
In this display mode, backfaces are colored pink to show what’s going on and I’ve circled the end of a horizontal cross-section curve:

The surface is a mess…
-wim

Ok, thank you.