Plan View Changes Scale

When I invoke Plan View in a detail, the scale changes from 1/8 to 1/7.903.
PLanViewChangesScale

Hi @djhg,

The last button in the toolbar is a macro that enables the level cut-plane, set the display mode to “Hidden” and finally zoom extents. This last zoom obviously changes the detail scale. This behavior is by design.

You can set a viewport to a detail by clicking the cut-plane button and changing the display mode.

Regards,

Enric

How do I enable door swings display? That last button seems to be the only one that does it.

The cut-plane button, the fourth in the toolbar in the level manager. It shows an square room sectioned horizontally.

Enric

Also, make sure the view is set to “Top”, so the view direction is vertical looking down.

And the plan cut level must go through a door. I wonder if that’s for the best.

Hi, if the level cut plane doesn’t cut through the door or the window but you want to see it in plan view, you can edit its “Plan Cut Elevation” from the properties panel, and set it to “Middle” (or type any other elevation).

2 Likes

Thanks Francesc.
Does that enable showing an open door with door swing below a wall cut, and not showing the opening cut in the wall?

Hi David, yes. The opening’s 2D representation is displayed according to whether they are cut by the level cut plane or not. With this option, you can override the elevation of that cut plane per door or window, so you ensure they are always displayed in plan view representation.

I am wondering how to take advantage of the benefits of zoom extents as part of “plan view”? If one wants to change the display properties between plan view and other modes, the detail window must be reconfigured each time plan view is set - I don’t see an upside. Also I don’t see an upside to changing the view to hidden? I’ve only just discovered that after “plan view” is invoked, one can change the View Mode to anything else and “Plan View” will still display door swings. Also, I don’t see how to turn plan view off.
As it happens, “plan view” doesn’t zoom extents if the active Detail window is locked.

Hi @djhg,

You’re right. Currently it doesn’t make sense to make a zoom extents, as you can have lines far from the real building, so the resulting zoom will be completely useless. However, in VisualARQ 3, the user can specify the contour curve of a building, so the plan view button knows the real extension to be used.

Hidden display mode tries to simulate a real printed plan view on paper, which has white background, visible lines, etc. There is no other display mode in Rhino that does this, apart from Technical, which used to be slower, doesn’t have white background, and doesn’t hide some tangent edges as Hidden. Moreover, Hidden display mode is printed in vector output like Wireframe.

You can turn off plan view by clicking on the “Cut plane” button in the Levels panel:

image

Enric

“There is no other display mode in Rhino that does this…”

Yes, thanks Enric. Hidden mode is a crucial element in my workflow, particularly for construction drawings. However for presentation drawings my plan views of textured coloured models are almost always in a view mode with ambient occlusion lighting, within either Rendered Mode or (more often) a version of Conceptual Mode which shows textures. So until I am producing final construction drawings, Hidden is seldom desired.

Hi @djhg, I guess you might be aware of this trick, but there is a workaround to get a vector output drawing with lighting. You can watch in this video how it works: 2D Vector Drawing with lighting in Rhino - YouTube