Piece of object diappears using guides. I'm sure I'm doing something wrong


#1

Just downloaded Serengeti. I was pleased to see a guideline tool. My first move was to lay in 4 guidelines and use them for a rectangle. However, one side of the rectangle disappears after completion. I assume I’m not using them correctly.
I can’t seem to order the images correctly. 2 is the final result. 1 is making the rectangle, and 3 is the Guidelines.


(Pascal Golay) #2

Hello - I think you are using them correctly- if you select the rectangle, does the whole thing highlight? And if you ClearAllGuides does it display correctly? Can you paste the output from SystemInfo into your response as well? Thanks.

-Pascal


#3

First. I get unknown command for “ClearAllGuides”. See pic.
Removing the guides one by one doesn’t help. The rectangle is still missing a side.

CAG

SystemInfo is:
Rhino 6 SR0 2017-11-7 (Rhino WIP, 6.0.17311.8431, Git hash:master @ c7eaf5f1ac3236bcd0758e2e49ceec44dfdf2949)

Windows 10.0 SR0.0 or greater (Physical RAM: 12Gb)

ATI FirePro V (FireGL V) Graphics Adapter (OpenGL ver:4.5.13413 Compatibility Profile Context FireGL 15.201.2401.1010)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.5
Shading Language: 4.40
Driver Date: NA
Driver Version: NA
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\CyclesForRhino.rhp “Cycles for Rhino”
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”


#4

Turns out this has nothing to do with guides. With no guides and using any method of closed curve creation, one area does not display. I’m getting similar out put with circles, ellipses, etc.


(Pascal Golay) #5

Yep, sorry! my bad - I’d made an alias for RemoveGuide > RemoveAll. (Seems like a reasonable command to me…)

At any rate just as a test, can you toggle the setting in Options> View > OpenGL for ‘GPU Tessellation’ and see if that makes a difference. Also… make sure you have the latest drivers for that video card.

-Pascal


#6

Yep. With “GPU Tessellation” unchecked the curves display correctly. Re-checked and it re-appears. What exactly is this and can I work with it in-checked?


(Pascal Golay) #7

You can work with that off - but I’ll mention this to @stevebaer - just in case it’s of interest.

-Pascal


(Steve Baer) #8

This is a bug in the FirePro OpenGL driver. @Luc brought this up with me this morning. We’ll see what we can do to report this to AMD.