Picture command crashing Rhino 7.0

The Picture Command regularly crashes Rhino 7.0. I had to use the Task Manager to close down Rhino. I even tried restarting the computer but the problem persisted. I had to save the file to Rhino 6.0 to get the Picture command to work without crashing the Rhino file.
This happens from time to time. I make sure to save my work before using the command if I am in Rhino 7.0
Dana

Hi Dana -

Please run the SystemInfo command in Rhino and copy/paste the results here.

-Pascal

OS Name Microsoft Windows 10 Pro

Version 10.0.19041 Build 19041

Other OS Description Not Available

OS Manufacturer Microsoft Corporation

System Name DESKTOP-VLQECRB

System Manufacturer Dell Inc.

System Model Precision Tower 3620

System Type x64-based PC

System SKU 06B7

Processor Intel® Core™ i7-7700K CPU @ 4.20GHz, 4200 Mhz, 4 Core(s), 8 Logical Processor(s)

BIOS Version/Date Dell Inc. 2.16.2, 8/13/2020

SMBIOS Version 3.0

Embedded Controller Version 255.255

BIOS Mode UEFI

BaseBoard Manufacturer Dell Inc.

BaseBoard Product 0MWYPT

BaseBoard Version A02

Platform Role Desktop

Secure Boot State On

PCR7 Configuration Elevation Required to View

Windows Directory C:\WINDOWS

System Directory C:\WINDOWS\system32

Boot Device \Device\HarddiskVolume1

Locale United States

Hardware Abstraction Layer Version = “10.0.19041.488”

User Name DESKTOP-VLQECRB\dana

Time Zone Eastern Standard Time

Installed Physical Memory (RAM) 32.0 GB

Total Physical Memory 31.9 GB

Available Physical Memory 23.4 GB

Total Virtual Memory 33.9 GB

Available Virtual Memory 23.3 GB

Page File Space 2.00 GB

Page File C:\pagefile.sys

Kernel DMA Protection Off

Virtualization-based security Not enabled

Device Encryption Support Elevation Required to View

Hyper-V - VM Monitor Mode Extensions Yes

Hyper-V - Second Level Address Translation Extensions Yes

Hyper-V - Virtualization Enabled in Firmware Yes

Hyper-V - Data Execution Protection Yes

image001.jpg

SystemInfo command in Rhino

Rhino 7 SR4 2021-3-8 (Rhino 7, 7.4.21067.13001, Git hash:master @ ed629035202f07e8b84a3ee211479ca20bb81b73)

License type: Educational, build 2021-03-08

License details: Cloud Zoo

Windows 10.0.19041 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.

Primary display and OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 5GB, Driver date: 10-30-2017 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 388.16

Accelerated graphics device with 4 adapter port(s)

  • Windows Main Display attached to adapter port #0

Secondary graphics devices.

Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 4-11-2020 (M-D-Y).

Integrated graphics device with 3 adapter port(s)

  • There are no monitors attached to this device!

OpenGL Settings

Safe mode: Off

Use accelerated hardware modes: On

Redraw scene when viewports are exposed: On

Anti-alias mode: 4x

Mip Map Filtering: Linear

Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation

Render version: 4.6

Shading Language: 4.60 NVIDIA

Driver Date: 10-30-2017

Driver Version: 23.21.13.8816

Maximum Texture size: 32768 x 32768

Z-Buffer depth: 24 bits

Maximum Viewport size: 32768 x 32768

Total Video Memory: 5 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino

C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.4.21067.13001

C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”

C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.4.21067.13001

C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”

C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.4.21067.13001

C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”

C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”

C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.4.21067.13001

C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.4.21067.13001

C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”

C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

image001.jpg

Hi Dana - the first thing to do is get the latest driver for your GPU from the nVidia website.

-Pascal

Hi Pascal,

Just downloaded the latest nVidia driver.

The picture command worked when I tried it. OK for now.

Thank you for your help!

Dana

image001.jpg

image002.jpg