Perspective Viewport Issue with Bongo View Constraints

I’m seeing an issue where the Perspective Viewport when set to “Rendered” mode is displaying nothing but black. This happened three times in separate files under specific circumstances.

If the resolution under “Rendering and Quality” is changed to “Custom: 1920 x 1080 (16:9)” AND a view constraint for example “Target to Path” is selected to a curve.

I did this with the “changing the resolution” step first and “setting the constraint” first. Both ways cause the viewport failure. I verified to make sure something should be visible by toggling the “Shaded” and "“Wireframe” settings.

Hi Jared - you did not categorize your post and I put it in the Bongo category.
Could you clarify that you are only able to get the Rendered display to turn black if you involve Bongo?
Also, please run the Rhino SystemInfo command and post the result here.

I’m not able to reproduce the malfunction. Are you using Rhino’s render or one from a third party?

Rhino 6 SR20 2019-11-18 (Rhino 6, 6.20.19322.20361, Git hash:master @ f60ce76e397bba419469ae5277fc1578641caa3a)
License type: Commercial, build 2019-11-18
License details: Cloud Zoo. In use by: jsaxon18is ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: COMRAD

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 6GB (NVidia) Memory: 6GB, Driver date: 8-16-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 436.02

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 8-16-2019
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.20.19322.20361
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Bongo 2.0 (64-bit)\Rhino6\Bongo.20.rhp “Bongo 2.0”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.20.19322.20361
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.20.19322.20361
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.20.19322.20361
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Bongo 2.0 (64-bit)\BongoUI.20.v60.rhp “BongoUI20v60”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Users\Jared Saxon\AppData\Roaming\McNeel\Rhinoceros\packages\6.0\rhino-render-next\0.0.2\RhinoRenderNext.rhp “Rhino Render Next”

Correct, only when a bongo view constraint is added does this occur.

now that you mention it yes, I was using “Rhino Render Next” those 3 times in the “rendering” controls while My Bongo render is set to “viewport render.” However I just tested this with “Rhino Render” selected first and the same error has occured. This I tested 3 times

Additionally, after this error has occurred, trying to set the Renderer back to “Rhino Render Next” from “Rhino Render” no longer works. When I Click on “Rhino Render Next” in the drop down, Rhino forces it back to “Rhino Render” instantly. This occured only once in my 3 tests.

@jsaxon18is - Could you please send us the example file and exact steps? I’m not able to reproduce this here, it seems to work fine with Rhino Render Next as the target render and view constraints.
What version of Bongo do you have installed? (Type in BongoAbout on the command line to get the version date).

Bongo Version: 12-Feb-2019

Whisper Room rotate.3dm (6.4 MB) This File for me will open up as is with the glitch.

glitch steps.3dm (11.6 MB) This file will glitch if I follow these steps.

  1. Under “Resolution and Quality” set “Dimensions:” To either: “1920 x 1080” or “1366 x 768” or “1280 x 720” or “852 x 480.” it appears to only be affected by aspect ratio. not resolution.

  2. with the “perspective viewport” active Open “Bongo View Constraints” and select “add constraints.” from the drop down menu select “camera to path” and select the purple line.

At this point the “rendered” Perspective Viewport should be just black.

Note: Toggling the viewport to “Shaded” reveals the object. and under “Resolution and Quality” setting “Dimensions:” to a resolution to something with a 4:3 aspect ratio will fix the rendered viewport.

I’ve tested this on my laptop step for step it doesn’t seem to occur. I’m thinking it must be hardware related. My GTX 1060 is on the latest nvidia drivers. is there away to test if its my graphics card?

I tested both models.
Nothing wrong, no black Viewport.
I use Radeon RX 580.

Hi @jsaxon18is,

Could you try going to Tools -> Options… -> View -> Display Modes -> Rendered and press Restore Defaults.

Does that help?

Sorry seems to have no effect.

Try this:

Delete the following folder: %TEMP%\McNeel\

Start Rhino and try to reproduce. If that doesn’t work rename the following folder: %APPDATA%\McNeel\Rhinoceros\6.0 to %APPDATA%\McNeel\Rhinoceros\6.0.backup

Start Rhino and see if you can reproduce the issue. Renaming the Rhino folder will reset all your custom settings, but you can get them back by reverting 6.0.backup to 6.0


Seems this is the solution. Thanks David.