Perspective becomes unresponsive in Rhino 8 for Mac

New to Rhino, using v8 (eval) on a MacBook Air 15" with Apple M2. I went through a couple of tutorials and have found my way around (avid Sketchup user). I noticed a few times that certain navigation stopped working (like panning in perspective), so I’d quit and restart Rhino 8 to get it to behave again. At this point restarting it doesn’t do the trick anymore… non of the modifier keys have any effect. I can only look around, not pan or orbit or zoom, in the perspective view.

What did I hose and how do I unhorse it… :wink:


Hi Edwin -

Is this behavior file-specific? That is, what happens when you start a brand new file from a factory-default template?
Also, please run the Rhino SystemInfo command and copy-paste the result here.

Oh interesting, I had not considered it to be model specific. But you’re right. Opening a new file behaves as expected. In fact, in the “stuck” model I’m in a “look around” mode (that’s how Sketchup calls it, not familiar with Rhino’s terms yet, where the camera position is fixed but the angle it points at changes with the right mouse button, or two fingers on the Mac laptop trackpad), which I’m not sure, is there even a modifier for?

Oh, more interestingly, now the new model got stuck in the same mode too. Let’s see, seems that when I use the Control (on a Mac) modifier it seems to get stuck in this “look around” mode and all modifier keys stop working (pressing one will block motion, releasing it returns to “look around”).

When opening a new file, right-mouse (double fingers on trackpad) rotate around the object (or 0,0,0 it seems), pinch to zoom works, command (on a Mac) + right mouse button zooms as well, shift + right mouse pans, now Option + right mouse button zooms also but towards a different center point and as soon as I use that, it gets hosed. I get stuck in the look around mode and no modifier keys work anymore.

As for SystemInfo, here you go:

Rhino 8 SR2 2023-12-12 (Rhino 8, 8.2.23346.13002, Git hash:master @ dbefe46c12cda06610a9ab683a211aa3d16f0030)
License type: Evaluation, build 2023-12-12
License details: Cloud Zoo
Expires on: 4686401-12-08

Apple macOS Version 13.5 (Build 22G74) (Physical RAM: 16Gb)
Mac Model Identifier: Mac14,15
Language: en-US (MacOS default)
.NET 7.0.0

Metal GPU Family Apple 7
Metal GPU Family Common 3
Metal GPU Family Mac 2
Graphics processors
Apple M2
Color LCD (1920 x 1243 @ 60.00Hz)

USB devices

Bluetooth devices

Third party kernel extensions

Third party plugins

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino “Renderer Development Kit” 8.2.23346.1002
/Applications/Rhino “Commands” 8.2.23346.13002
/Applications/Rhino “Snapshots” 8.2.23346.1002
/Applications/Rhino “RDK_EtoUI” 8.2.23346.13002
/Applications/Rhino “MeshCommands” 8.2.23346.13002
/Applications/Rhino “Rhino Render” 8.2.23346.13002
/Applications/Rhino “RhinoCycles” 8.2.23346.13002
/Applications/Rhino “AnimationTools” 8.2.23346.1002
/Applications/Rhino “SectionTools” 8.2.23346.1002
/Applications/Rhino “Displacement” 8.2.23346.1002
/Applications/Rhino “PanelingTools” 8.2.23346.1002
/Applications/Rhino “IronPython” 8.2.23346.13002
/Applications/Rhino “Grasshopper” 8.2.23346.13002
/Applications/Rhino “RhinoCodePlugin” 8.2.23346.13002

Thanks for your help!

  • Edwin

Correction: using the Option modifier hoses it, not Control (on a Mac).

Are you using the trackpad? do you have a 3 button mouse you can try?

I’m using the trackpad indeed. Don’t have a USB-C or bluetooth mouse nearby currently.

Hm, this bug (I’m going to call it a bug now that it’s replicable and isolatable) seems to relate to the trackpad only. I tried it with a mouse and was unable to replicate. Also, I found a way how to get it to return to normal, using any of the zoom aliases, like ZS (zoom selected). So, I guess it’s workable again. Definitely a bug though.

For me ZS doesn’t work on Rhino7. I’ve also found this problem on 7 many times, I thought that it was a problem with my old Mac book. Sorry to find out it’s also a problem on Rhino 8.

ZS in Rhino 8 is set up as an Alias for '_Zoom _Selected.
I can access the same by entering the _Zoom command and entering S (or clicking on Selected).

Let me know if that works for you.