Persistent Chain Selection in Fillet Command

Is there any way to make the fillet edge command stay in chain selection mode without having to re select it? On occasion I need to select multiple edge loops and find myself repeatedly returning to the command line to click chain. The keyboard shortcut doesn’t help much as you also have to press enter. An option to have the chain option locked on would be a big help - does this option exist and I’ve just missed it?

Thanks for any help offered.

Hi MisterB - a macro:

! FilletEdge Chain AutoChain=Yes

should do it.


1 Like

Thanks, Pascal. Learning about macros, scripting etc. has been on my to do list for ages. I must find some time to learn the basics.

Again, thanks for your help.

I have same issue, once I select chainEdges I see AutoChain= yes, so hit enter to move on in command and yet still get to select only one part at a time.

There is no way to lock the chain edge yes option to ‘on’
I then paste the macro in this thread by Pascal, into the command line and can select my first part and get the entire edge, thats good. :slight_smile:

then I select the next item and we are back to bit by bit :frowning:

I then paste that macro in and this time its still bit by bit. :frowning_face: :rage:

I start the command for filletEdge all over again, select chain edge and displayed is AutoChain= yes, I hit enter to continue and can only select bits.

What am I doing wrong when trying to even initiate chainEdges in this command.

Also why does the macro not work after the first time ?