Permanently turn off annotation scaling & history warnings


(daveed kapoor) #1

i turn off annotation and layout scaling every time i open i file, even if it is off in my template, any time i open an old file it is on, and so frustrating. is there a way to globally disable this feature on my installation?

also the break history warnings are killing me! one of my favorite features of rhino vs. revit was the lack of pop up dialog boxes that force you to read and click thru disturbing our workflow. any way to globally disable, if that makes any sense?

best thing about rhino 6 is artic mode ! so good. and the fraction text + change case is excellent…


(Wim Dekeyser) #2

Annotation scaling is a document property and thus not something that is controlled at global application settings. One way around this would be that you import old files instead of opening them. That way, your template settings will be used.

You can disable History Break Warnings by right-clicking the Record History setting in the status bar:
image


#3

“Annotation scaling is a document property and thus not something that is controlled at global application settings. One way around this would be that you import old files instead of opening them. That way, your template settings will be used.”

Greetings Wim - This is my single biggest frustration with V6 - Dimension scaling is on by default.

So, a better question is: Where can I set the V6 default document properties? Can we get so lucky as to simply edit a text or xml file somewhere?


(David Cockey) #4

You can create your own document template files. Open Rhino, set the document options as desired, and then save those settings into a template using SaveAsTemplate with any name you want such as dentemplate.

You can then set any template file as the default template to be used which will be used when opening a new file unless a different template is selected. Options > Files and under Template files select the desired template file as the default template.


#5

Greetings David,

Yes, this was assumed to have already been done by the recommendation to import older 3dm files instead of opening them.

To that recommendation I have only to say:
Why should I need to work-around the V6 program to use older 3dm files? Why does V6 not check for older files at file-open time and run a V5 friendly document settings default setting?


(Wim Dekeyser) #6

You shouldn’t have to do that. I read the OP as RH6 correctly reading an RH5 file with unwanted document properties. It appears that something else is going on. I’ll check some more.


(Lowell Walmsley) #8

There are a lot of combinations of how people set up their V5 drawings.
We make some adjustments to try to accommodate those things in v6, but it’s obviously not working right for you.
It does work pretty well in some cases, so we need some clear details about what isn’t right for you to understand the problems.

If you post a small example v5 file with a text and a dimension object that don’t display right in v6, I’ll see what I can figure out. Big or complicated files make it harder on this end.

Thanks,
Lowell


#10

858800.3dm (113.6 KB)
851100.3dm (4.9 MB)

Greetings Lowell,
Yes, there are quite a variety of ways. Here are a couple of V4 drawings that display 2 if my frustrations.

  1. dimension scaling is on by default - which causes all text strings to be scaled up from when opened in V6
  2. dimension numbers don’t show up. Exploded dimensions and tolerance text strings do, but the actual dimension number do not.

Open these up in V4 or V5 - and then again in V6 - and you will see what is going on.


(Lowell Walmsley) #11

Thanks for the examples. These problems are fixed now in 6.x. I think it was in time for 6.5

https://mcneel.myjetbrains.com/youtrack/issue/RH-45937
https://mcneel.myjetbrains.com/youtrack/issue/RH-45938
https://mcneel.myjetbrains.com/youtrack/issue/RH-45939


#12

Many Thanks Lowell !


(Brian Gillespie) #13

RH-45937, RH-45938, and RH-45939 are fixed in the latest Service Release Candidate


#14

Greetings All,

A big Thank You to all the developers at McNeel for addressing this issue so quickly.
6.5.xx is awesome.