Performance tanks during Fillet edge

Not sure why, but recently Rhino 7 appears to have a considerably worse performance while the “Fillet edge” command is active, in comparison to the earlier builds from the past few months. I tried several recent Nvidia drivers from 2022, as well couple of older drivers from 2021, but the framerate often drops to below 1 frame per second. Rhino have been always slower during “Fillet edge”, but the last couple of Rhino 7 Service release candidate updates made it much, much slower. The performance is especially bad in Shaded view. I also reset it, but it’s still extremely slow. My custom viewport modes are 5-10 times faster. Most likely the environment map used in the Shaded viewport is causing some slowdown. Just an assumption.

In this particular video, I turned on the framerate counter (on the upper right corner of the screen) which is built into GeForce Experience, the gaming tool of Nvidia that measures the framerate. On a few occasions the number even disappears, which means that the framerate dropped below 1 frame per seconds.

How does it perform when the filet command isn’t running?

What frame rates get reported while running TurnTable in Shaded mode (again, without the filet command running)?

The performance while not in the Fillet command is perfectly fine, with 40-60 frames per second most of the time even on complex scenes. The problem comes when I want to apply a fillet. The performance drops hugely in that very moment, even on relatively simple objects. It was not that bad a few weeks ago.

As for the Shaded viewport mode, it was always considerably heavier than using my custom viewport modes (even on Rhino 5 and 6). I have seen multiple Rhino users report the same issue over the past few years in various topics here. They also saw noticeably better performance with my main custom viewport mode called Bobi 1, compared to the default Shaded mode.
Bobi 1.ini (13.8 KB)
Bobi 2.ini (13.8 KB)
Bobi 3.ini (13.8 KB)
Bobi 4.ini (13.8 KB)
Зайо Байо.ini (14.5 KB)
Чертеж 5.ini (12.7 KB)
Чертеж 6.ini (13.9 KB)

Some of my viewport modes above use the following environment maps:

Bobi 3 and Bobi 4:
brushed_silver

Зайо Байо:
fon 1 za Zaio Baio

fon 2 za Zaio Baio

Hi Bobi -

Could you post or upload a simple example in which you notice this performance drop?

Do you have an older installer laying around that you could test? If not, can you be more specific about which version that might have been that was still good?
-wim

Not sure if Rhino 7 will let me downgrade to an older version. If I uninstall the program, it may mess up with my custom toolsbars and scripts I added to many buttons. The issue with massive drop in performance while doing fillets started immediately after upgrading to the latest Rhino 7 SR18. Windows 10 and the drivers were not changed in the days before the issue. I also updated Windows 10 and tried multiple Nvidia drivers after upgrading to Rhino 7 SR18, but the bad performance is still present. Outside fillets, the performance is OK (except that Shaded viewport mode have been slower than my custom modes for no obvious reason since years).
But as I mentioned in another topic here, there was also another issue with my 3d mouse’s automatic camera center of rotation that started to stick to a point and refusing to re-adjust to another surface area.

I will send a sample 3d model to the McNeel support e-mail. I have added some fillets on the same model just before the update and Rhino 7 SR17 was fast then. However, on the next day I continued to work on the very same part, but this time in Rhino SR18 and I immediately felt the considerably slower performance.

I suspect it’s because line drawing is weirdly expensive, and the shaded mode not only draws both polygons and lines, but must do a lot of visibility culling on those lines that no other mode has to do.

Hi Bobi /

No, reverting to a previous version should not mess with this. Granted, I only have a single toolbar with 3 custom buttons but I’ve yet to run into an issue with reverting to an older version. In the end, of course, it’s your responsibility to make sure you have a backup of files that are important to you.

Note that SR18 doesn’t exist yet. The current final Service Release is still SR17.
So far, there have been two Release Candidates for SR18: 7.18.22102.09001 and 7.18.22109.05001.
From your description, it’s not clear if things changed between those two or from some SR17 Release Candidate.

If it’s only the very latest version that you installed that changed things, you should be able to see which version you used before that (or, at least, which version was automatically downloaded):

C:\ProgramData\McNeel\McNeelUpdate\DownloadCache

That folder contains folders for downloaded versions.
-wim

Hi @wim , I usually install the latest Service release candidate, in order to get the newer enhancements and bug fixes available. Some of the fixes proved to be really important to me. Recently I upgraded from Rhino 7 SRC17 to couple of Rhino 7 SRC18 versions. I delete the older installers to save space on my HDD. Currently running the latest available Rhino 7 (7.18.22109.05001).

In the past I have been doing a few re-installs of Rhino and lost some of the customized toolbars or certain scripts added manually to my custom buttons, so I avoid downgrading to an older version. I will probably wait for the next Service release and hopefully it will perform better.

By the way, I’m just sending you an e-mail with the 3d model from my video above to test it on your machines with various viewport modes.

It’s interesting to know that the latest Rhino 7 SRC18 have considerably worse performance while trying to open some older heavy scenes (slightly above 2 GB) that were perfectly working on the earlier Rhino 7 builds from one year ago. While working on those old files now, at some random point either Rhino crashes or my entire Windows 10 freezes.

Run SelBadObjects on it.
It lights up your polysurface.
ExtractBadSrf pulls it out of the polysurface.

My guess is if you fix that, the problem will go way.
I extracted the bad surfaces and then FilletEdge previews just fine.

I usually have the _CheckNewObjects command turned on all the time, but looks like it was turned off at some point. :slight_smile: However, even when I extract the bad surface, the performance is still extremely bad upon the preview of the fillet on that particular model (no matter if I use Shaded, Wireframe or any custom viewport mode). The framerate drops to under 1 frame per second. That also happens on any other model and file that I have tested in the last couple of days.
On a side note, I wonder why my custom viewport modes are multiple times faster than the default (unaltered) Shaded mode…

Since the huge drop in performance only happens during the preview of the “Fillet” command that exposes all the surface isocurves temporarily, I just wonder if that means that the geometry is being rendered multiple times simultaneously? Is the GPU or CPU responsible for the rendering of the preview isocurves at that particular moment? My CPU is quite old (but still performing perfectly fine) - Intel Core i5-4460 from 2014, while my GPU is Nvidia GTX1660Ti from 2019.

Just downloaded and installed Rhino 8 WIP. Performance during Fillet preview is at least twice as bad compared to Rhino 7. Extremely bad. :space_invader: I expected Rhino 8 WIP to be faster…
Also, the viewport rendering quality in Rhino 8 WIP is noticeably worse than Rhino 7 when opening the exactly the same file with exactly the same viewport settings and default meshing (Jagged and faster). Not sure why it’s like that. Meshing in Rhino 8 WIP seems to hide the seams of the polysurfaces in certain areas. Also, the highlights of the environment map in Rhino 8 WIP are lower quality and don’t blend smoothly across the triangles of the polygon mesh. Geometry in Rhino 7 looks much, much better.

Latest Rhino 7:

Latest Rhino 8 WIP:

Latest Rhino 7:

Latest Rhino 8 WIP:

Latest Rhino 7:

Latest Rhino 8 WIP:

1 Like

I’m going to call this a bug and send to the dev team for review- https://mcneel.myjetbrains.com/youtrack/issue/RH-68394

1 Like

I also think it’s a bug. Hopefully it will be resolved soon.

Anybody else experiencing often crashes with the recent Rhino 7 Service release candidate 18? Rhino 7 SR17 was much more stable. Over the past 20 years with Rhino I have never seen “Instability alert” error (like the one shown at the 28:40 minute in this video), however, now it happens almost every day. Usually it appears after Rhino is struggling to calculate the rendering mesh after joining more complex models.

Rhino 7 SR18 2022-4-19 (Rhino 7, 7.18.22109.05001, Git hash:master @ 5d55cd37fa4ae8704a5b5854b391e990452b7b1e)
License type: Commercial, build 2022-04-19
License details: Cloud Zoo

Windows 10.0.19044 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1660 Ti (NVidia) Memory: 6GB, Driver date: 3-17-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 512.15
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-17-2022
Driver Version: 30.0.15.1215
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
D:\PROGRAMI\Rhinoceros 6\Plug-ins\Stereoscopic 3d viewport\StereoView.rhp “StereoView”
C:\Program Files\ADA 3D\Mesh2Surface for Rhino 6\m2s_for_Rhino.rhp “MESH2SURFACE”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.18.22109.5001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoLabsTools.rhp “Rhino Labs Tools”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.18.22109.5001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.18.22109.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.18.22109.5001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.18.22109.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.18.22109.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

1 Like

this is fixed in the latest update- let us know if you see it perform differently.

1 Like

RH-68394 is fixed in Rhino 7 Service Release 19 Release Candidate

On my Rhino 7 SRC19 (the last one from today) the problem still persists. The performance is extremely bad (less than 1 frame per second) while trying to add a fillet in Shaded viewport with hidden tangent seams:
Shaded.ini (13.9 KB)

Performance is bad (1-2 frames per second), but tiny bit better with the default Shaded mode with visible tangent seams:
Shaded 2.ini (13.9 KB)

Best performance I see (basically 5-10 times higher framerate than the default Shaded) is achievable while using my custom viewport mode:
Bobi 1.ini (13.8 KB)

I try this on the same 3d model which I sent to the “McNeel” support from the link for bug RH-68394.

1 Like

Thanks, I reopened the issue.

1 Like