Pen Mode - Items Suddenly Transparent

Having an issue where a file that used to display/print OK using Pen mode, but opening it later to edit it, the Pen mode almost looks like a cross between Pen and Wireframe.

Before (printed to PDF):

After (still in Rhino, using Pen view - the fillet on the front disc was not the cause, the hardware was already showing up this way before filleting):

All of the detail views used to make the exploded view are set to Pen.

System Info

Rhino 8 SR6 2024-4-10 (Rhino 8, 8.6.24101.05001, Git hash:master @ 32c244aa711e0034e75bec2e87d093c764820b96)
License type: Commercial, build 2024-04-10
License details: Cloud Zoo

Windows 10 (10.0.19043 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.17

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2060 (NVidia) Memory: 6GB, Driver date: 4-11-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 552.22
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port 0
- Windows Main Display attached to adapter port 1

Secondary graphics devices.
Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 6-1-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-11-2024
Driver Version: 31.0.15.5222
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\BlockEdit.rhp “BlockEdit” 8.6.24101.5001
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Is there any solution to this, like a RegenAll in the olden days of AutoCAD?

1 Like

Hi Scott - if you set Pen to defaults, does it clean up?

-Pascal

2 Likes

Hey Pascal - just tried it, no luck. Can’t upload the file here (it’s actual client work), what’s the email/way to upload to send it to you folks again?

1 Like

Hi Scott - please send to tech@mcneel.com with a link back here in your comments.

-Pascal

2 Likes

Perfect, thanks. Sent.

Worth noting - it only appears to be happening in detail views; model space Pen view looks 100% fine.

1 Like

@ssommerv I did not see any files coming in from you.

1 Like

@Gijs - @pascal has already been in contact with me via email re: the files that I sent. I sent them from my work email though, not the email that’s listed on my account. (Minor brain fart, I had the work Outlook open and just sent it from there)

2 Likes

Hi Scott - there are linked block instances missing - can you send the linked file that has the objects you show in your image above?

-Pascal

1 Like

Hi Pascal - the only linked block in the file was included in the ZIP file in my last email. All the rest are embedded.

(Edit - though just in case, all of the blocks that weren’t defined in the file are also in the ZIP)

@pascal - let me know if that second email with the ZIP of the blocks didn’t make it through, I can totally resend.

Trying some things for myself…

Shaded mode - erroneous transparency is gone, objects look normal.

Pen mode - transparency is there.

Shaded Pen (a mode I created that just shades everything in white, so that the detail views can overlay each other without being see-through) - transparency is there.

Technical - hidden lines aren’t hidden.
Artistic - Same deal, “transparent” behavior where hidden lines show.

Monochrome - kind of shows through, but less?

Arctic - weird kind of woodgrain look to everything.

Went to BlockEdit to see if maybe there’s a bug with the block geometry; tried SelBadObjects inside the block but no result there, and can verify that they’re closed polysurfaces.

Hi Scott - sorry - I do not see your zip file - can you please try again to
www.rhino3d.com/upload
thanks.

-Pascal

1 Like

Done!

Hi Scott - thanks, got it this time, I am taking a look.

@ssommerv - it looks to me like the camera in those views is unnecessarily far away from the objects - as a consequence, the depth testing is breaking down and the objects in the view end up in one of 256 possible depth-buckets from the camera. The distance from the camera to the target is 39,000 units - and the objects are one or two units in size. The camera frustum is so narrow it displays as a line:

image

Moving the camera nearer lets the depth be sorted more precisely

I moved the camera by

  1. Creating a named view from the detail view.
  2. Showing the camera widget for the view (my first image)
  3. Turning on control points for the camera widget.
  4. Unlocking, temporarily, the detail.
  5. Set Gumbal to By object and select the camera point. Move it using the blue Z gumball axis way in towards the objects.
    Make sure the detail is now set to that view and lock it again.

-Pascal

2 Likes

That does the trick, thanks @pascal . You folks continue to be awesome.

I would typically invert/hide in detail to isolate the objects for my exploded views. Usually I’ll then set the zoom level using the detail view’s scale. Is there a way to avoid having the camera end up over half a mile away from the object I’m trying to view?

Hi Scott - I was asking myself that question, and I don’t know - I’ll have to check with the developers.

@ssommerv - the distant camera seems to occur when you set the scale from a view/camera that is not especially ‘correct’ for the objects you want to look at - in this case, I am guessing the scene is a lot larger and at some point your view was backed out quite far - setting the scale then narrows the frustum but does not adjust the camera location. Zoom Selected then setting the view and scale may help avoid this.

@ssommerv - in case it helps if you run into this again - here’s a script that you can run to set the camera to target distance. Make the detail view active, unlock it, and then run the script - set the distance to say 100 to clean up the x-ray effect.

To use the Python script use RunPythonScript, or a macro:

_-RunPythonScript "Full path to py file inside double-quotes"

AdjustCameraDistance.py (2.1 KB)

-Pascal

1 Like

Yes - the whole space we’re designing exhibits for is about 30ft x 30ft; the objects details are on the scale of 1 to 2 inches.

I’ll keep the camera distance and your script in mind going forward. Thanks again!

Hey Pascal, any updates from the devs on the camera placement? I continue to have issues where I’ve set the scale appropriately for an object, checked that the camera placement in the Properties tab is reasonable, locked the view, and come back to find the camera at a position 2 miles in the distance…