PDF Printing Troubles

DM-ed.

Thanks for taking a look.

Sam

There’s definitely something funky going on with that font. I contacted the company that writes the PDF toolkit we use about this and will come up with some sort of work around for when situations like this happen.

I just put in a fix so at least Rhino falls back to Arial when it fails to use this font. This will be in the next SR3 release candidate. Will still investigate why this particular font is acting up.

Here’s a screengrab of the print settings. It happens on both vector and raster setups.

-Nick

Thanks, I can reproduce it now: https://mcneel.myjetbrains.com/youtrack/issue/RH-44742.

-David

RH-44699 is fixed in the latest Service Release Candidate

Has anyone been able to get this to work yet? I keep checking the release candidates but they still aren’t working properly for me. Today I tried Version 6 (6.3.18086.1061, 3/27/2018) Evaluation. I’d like to know if it’s just a Rhino issue or if there’s something I should be looking at elsewhere on my system.

The test: I open Rhino using the Small - Inches provided template, draw a cube, create a layout using Rhino PDF/Tabloid/Landscape, set detail to perspective/rendered, add picture and print.

The result: Open file in Acrobat, the detail shows up fine, no picture and an error message that literally just says there is an error and to go contact myself! 8^) (the creator of the PDF)

Thanks!

Hi @ainsley,

The YT item linked below should be fixed now, and available in Rhino 6 SR 4 Release candidate 1. If all goes well SR4 RC1 should be available by tomorrow.

https://mcneel.myjetbrains.com/youtrack/issue/RH-44742

-David

Hi @DavidEranen ,

I’m still having no luck here, today I tried installing it on a second computer as well just to see if there are any hardware/driver/software conflicts and am having the exact same issue.

I’m currently using version 6 (6.4.18100.1591, 4/10/2018) Evaluation

Hi @ainsley,

I can verify that it doesn’t seem to be fixed in Rhino 6 SR 4. Something must have gone wrong. I reopened the YouTrack issue: https://mcneel.myjetbrains.com/youtrack/issue/RH-44742.

RH-44742 is fixed in the latest Service Release Candidate

Works like a hot damn now! Thanks guys!

2 Likes

Hi im having some more problems printing with rendered details. I am using the default settings for the rendered display mode, except I have the lighting method set to ambient occlusion. I am running the current release candidate.

When I try to print a view of a simple sphere, it goes extremely slow and the whole system slows my display. till it usually crashes.

I am printing with the same settings as the file above.
Thanks!

-Nick

Hi @nscross,

Yes, this is a known problem. https://mcneel.myjetbrains.com/youtrack/issue/RH-42814.

The only workaround I know of is to reduce the output resolution, or to disable skylight/ambient occlusion.

Hello,

As mentioned above, I am having trouble printing any rendered images in layout space. Raster mode. Not sure if it even works in Vector mode to begin with.

They simply do not show up. My details as well as any text in layout space will print.

This was not an issue in Rhino 5 and like many people have mentioned in this thread its a huge issue when printing for a studio that uses this feature daily.

Can you please let me know when this will be fixed.

I am using V6 SR7 (6.7.18183.14071)
using an Nvidia GTX 980M with up to date drivers

Can you send me a file that isn’t printing properly? I would like to try and repeat this bug.

Hi Steve,

I am attaching supporting documents to explain. Hope this will push in the right direction!

Thanks for your help!

Rhino_print test.3dm (5.7 MB)

Checking back in here. The issue still is happening. But less often now.

Ive been running into this issue quite often with rhino 6 and i really have no idea how to fix it. It happens on both my computers randomly. One runs a 1080ti and the other a 980m.

Its especially annoying in your layout views when trying to set up display modes. everytime i go to print they disappear. Well half of them do. I thought it was a glitch, but even when i remake the surface its happening. Delete the texture completely and retry, still nothing.

I wish that i could hold a texture when i print a detail. sometimes it works, sometimes it doesnt.

I do like the new rhino pdf exporter :slight_smile:

Please let me know if im not doing something right…

Thanks for your time.

A post was split to a new topic: Printing problems