PDF Import Problems (PDF-version, embedded fonts)

I have two problems with the PDF import:

  1. Some pdfs can’t be imported (Bad Reference). If i convert them PDF1.4 they can be imported but
  2. Text doesn’t show. I suppose that’s because of non-standard fonts even they are correctly embedded and do show on different pdf-readers. If i replace the fonts with standard fonts (manually with illustrator) the text is imported to rhino.

is there an workaround for these problems? I’m working on V5 but experience the same problem in V6 WIP.

Hi Heiko - can you please post example pdfs or send them to tech@mcneel.com if they are confidential?

(files received, non-public YT item made.)

thanks,

-Pascal

This bug is fixed in the latest WIP

Hi, it’s me again with the same problem…

Issue 1 is fixed in WIP
Issue 2 (Text not showing) still exists in latest WIP (6.0.17355.10131, 12/21/2017)

Best regards,
Heiko

I am having the same problem!

Hi - please provide both the result of the Rhino SystemInfo command and a *.pdf file that causes problems.
-wim

1775_C103_2019_06_25.pdf (514.8 KB)
system info.txt (2.2 KB)

I am having now a different problem with the PDF import.
When I use Foxit reader (https://www.foxitsoftware.com/downloads/) to ad lines, texts and symbols to a PDF and I try to import it to Rhino, al the shapes created by Foxit are not imported into Rhino.
I don’t know if it is possible but it would be nice if Rhino also supports geometry created by this program.

Doorsneden.pdf (1.4 MB)

Hoi Erik - looks like this thread got overlooked, sorry about that!
First about that previous issue, it looks like that 1775_C103_2019_06_25 PDF gets into Rhino 7 without problems here. Are you seeing the same?

About the new issue - when I have issues with getting a PDF into Rhino, I always take it into Inkscape first to see what gets in there. Most often, Inkscape reads it all and I can then ungroup everything and export to PDF and that will then normally also get into Rhino. For this one, Inkscape doesn’t import the added lines, text, and symbols either. So, I’m not sure what can be done here but I’ve put it on the list as RH-56184.
Thanks,
-wim

Hoi @wim,

My problems with the 1775_C103_2019_06_25 PDF where solved by mail I think.
Importing texts is going fine now! Thanks.
I hope the issue with the Foxit created PDF’s can also be solved.
When I open these files with Acrobat Reader or Firefox all information is shown.

RH-56184 is fixed in the latest Service Release