PBR Material not getting rendered on the actual surface?

Wondering what I am doing wrong? The small object is just surfaces, and the box is a solid cube. The smaller shape has the edges and corners detailed with points and lines. You can see the material is rendering “below” the surface. Same on the cube.

Is there some kind of displacement applied?

Or are you literally miles and miles from world 0,0,0?

Not too far from 0,0,0. Here’s a Rhino material rendered.

lower or disable the displacement-

I had no idea that was even a thing. Thank you!

displacement is cool ,and can yield awesome results, but it does move (displace) the surface, and is best used in areas where edges don’t have to line up perfectly or are hidden from the camera.

1 Like

Or you can mesh the object (with a very fine mesh) and weld it at an angle over 90° (or higher, depending on your geometry), so that the surfaces are all seen as one. Then the displacement will “carry over” at the edges without problems. It would be nice if you could set a weld angle in the custom render mesh options, actually!

HTH, Jakob

This is indeed the most important part.

It is good to know that in Rhino meshes created for extrusions, breps, polysurfaces etc will have at hard edges disconnected geometry. So the six faces you get from a simple _Box by default will be not connected to each other in mesh. This is what causes objects to ‘explode’ when you apply materials with displacement.

Hmm, RenderMesh option for welded Edges would by nice. :thinking:

1 Like

100% agree-