Paste offset

After the most recent update I’ve had issues with copy/paste. It seems when I attempt to paste an object it offsets to a different location. From what I can tell it seems to paste at the same X coordinates, but goes to the 0 of the Y coordinate. This happens even when I check the “In Place” box. I’ve quit out of Rhino and even tried restarting my iMac in attempts to fix the issue.


I cannot duplicate this, but I am not doing what you describe. [quote=“as32090, post:1, topic:6431”]
This happens even when I check the “In Place” box.

The Paste command has no such option, in fact it has no options, so I don’t know what command you are actually running.

I should clarify, the “In Place” option was referring to the Copy command. Is there a way to set a predetermined offset for Command+C/Command+V? I now know the offset distance and direction stays the same and is not referencing the Y 0, didn’t know if I managed to set this accidentally.

Command-C runs the CopyToClipboard command, not the Copy command. I don’t know if the Copy command remembers previous values or not when running the command a second time. You might run the Copy command and check to see if non-zero values are filled in when you run the command.

I’m experiencing the same issue as listed here. When I run the copy command it works as it’s supposed to, but when I use the keyboard shortcuts the objects are now offsetting… Was this issue resolved previously and if so how?

I’ve had this problem multiple times already and somehow the problem always seemed to magically disappear.
But I’ve had it recently and it was really slowing me down and in my despair I found the command ModelBasepoint and realized that my base point wasn’t the world’s origin. I set it back to 0 and voila, it fixed the problem, no more offsets.

I hope this helps! :blush: