Part of polysurfaces not showing after sweep 1 despite appearing in preview

I’m trying to make a doorframe using sweep 1 command.

It appeared fine in the preview:

But after I pressed “ok” the right part is gone:

Tried deleting the skirting beside it to see if it was because of the neighbouring skirting insecting with the doorframe, but problem was still not solved:(

doorframe 2.3dm (2.0 MB)

Explode the door frame polysurface and run SelBadObjects. Several of the surfaces are “invalid”. How did you create those surfaces?

When uploading a file it is best to only include the parts which are directly related to the question.

Thank you for replying. I am new to this community so thanks for the reminder :slight_smile:

I created the shapes by drawing rectangles then replace front part of the rectangles with arcs:

<-top view

I created the doorframe by tracing the outer edges of the shapes aforementioned then connect it to a “rail”:

How did you trace the outer edges of the shapes? Which commands did you use?

Can you post a file with the curves you used for creating the surfaces?

I think I used dupedge.

Here is the file. I kept the skirting and floor for reference.

doorframe 3.3dm (1.94 MB)