Parametric Validation

I am having a problem with parametric validation. It worked well before, but now it does not show up anywhere on the page. I like the feature for speeding up the user experience and having less of the “lag”.

Any thoughts? Link to the page is below:

I agree, it’s a great feature for large models but it worked fine for me. Do you use different computer or browser than before? I’m just wondering if there is anything else what changed.

Also, can you check browser console for any errors?

Hi Pavol, I tried both Chrome and Edge browser and it’s still not working. I see your screenshot is of the “viewer setting” page. I don’t have the issue there. The issue is after I click “apply settings.” The page where I interact with the model the validation does not appear.

I assume you mean your page where you embed the model, not the ShapeDiver platform, right?

Here:


https://app.shapediver.com/m/test-2093344 does it work on your end?

No, I don’t see it either and the Parameter Validation is switched off in the model settings. Did you save it activated in the Edit Model mode?

Yes, I tried it several times. Maybe try it with a different model?

I managed to replicate it, there seems to be a bug with saving of the model settings. My apologies for the inconvenience, our dev team will look into this and I let you know once we have any news.

1 Like

Hi Guys, has this been looked at?

I’ve just uploaded a new model and spent HOURS on getting the parameters into the correct order.

But now PARAMETER VALIDATION keeps tuning itself off every time I try and edit it.

(Also how are you going on being able to set parameter order?? I really really hate doing any updates on your service due to stupid time it takes to re order parameters. Its 2021 gents - this should be automated by now)

Cheers

DK

The bug has been already reported but it slipped through the cracks and I’m really sorry for this. Our developers are working on the issue and we will release a fix soon.

The planned platform upgrades will make uploading models a lot more easier with parameter ordering and grouping. The new version of our plugin will be released in following month or two.

Thank you for your patience and once again my apologies for the inconvenience.

@kiteboardshaper, we have just released fix for saving the parameter validation option in model settings.

I’m sorry that it took so long and let me know if there is anything else I could help with.

1 Like

Thanks, my update has loaded up fine.

Looking forward to the new parameter order being remembered too.

Cheers

DK