Parameter name: index Index was out of range. Must be non-negative and less than the size of the collection

Recently I’ve started to get a strange message whenever I move an item. The message doesn’t seem to produce an error but it happens for every item I move, multiple times if I move more than one item at once. I have the newest version of Rhino and I’m on 10.11.4.

I believe this is coming from some Python or C# code. What extras and/or plug-ins have you installed to use with Mac Rhino?

Looks like the plugins were it. I installed this plugin on the Rhino WIP. Once I removed that plugin the errors stopped. I guess Rhino and RhinoWIP share a plugins folder?

HI @gent,

thank you for your observation. It’s correct, both versions share a plug-in folder.

The mentioned LayerClasses plug-in doesn’t work with Rhino 5.1, though.

Did it load automatically in 5.1 every time you started Rhino?

Edit: is the respective file one that you created with the WIP?

@thomas I never noticed it being loaded in Rhino 5.1 and I never tried to use the plugin in 5.1. I didn’t create the respective file in the WIP but I definittly edited it with the WIP at one point.

EDIT: I just reinstalled the plugin to test and it looks like the commands are available in 5.1 even though the plugin was installed in the WIP.


thanks for helping us to track down this issue. A few questions:

  1. Do you recall if you had the plug-in loaded / in use when you edited the respective file?
  2. What about this error message you posted here a moment ago? It seems to me that this message should not happen…
  3. It is expected behaviour to have the plug-in (and its commands) show up in 5.1 even if you install it in the WIP (although this is not very convenient in this case). The commercial and WIP versions share settings and their plug-in directory, so, any plug-in you install in either, shows up also in the other app.

No problem, glad to help.

  1. I did have the plug-in loaded when I edited the respective file.
  2. The original error I posted a moment ago was due to me grabbing the windows version of the plug-in instead of the mac version. Installing the correct version of the plugin gave no errors.

OK, thanks.

I’ll look into it. Hopefully, the problem goes away when 5.2 will be released…

Hi @Thomas

I just had the same error message with LayerClasses on rhino Mac 5.3.2. I guess I instaled a Win version of the plugin intead of a Mac one.
My problem is that I don’t know how to unistall this plugin.
No plugin file in Rhino/preferences or File/settings
No LayerClasses file on computer : App/Package contents Rhino/PlugIns
and in About Rhino/more info : Plug-ins : None ???

How to manage plugins in Rhino or Wip?

There is no plugin manager in Rhino 5 for Mac (we are working on one for Rhino 6 for Mac).

In the meantime, you can “manually” manage which plugins Rhino 5 for Mac loads by using Finder. Navigate to Finder > Go > Go to Folder… and enter:

~/Library/Application Support/McNeel/Rhinoceros/MacPlugins

Each time Rhino for Mac starts, it will attempt to load plugins from that folder.

I removed the crashed plugins. Everything’s ok now