PangolinMesh won't install

So, I’m trying to install PangolinMesh, but nothing happens when i press “Install”.

The best I could achieve was having the installer tell me I need to install Rhino, which has been installed on the computer for “many years.”

Win10, Rhino 7, with the license registered on Zoo. The Rhino 7 version I have installed seems ok:

image

Perhaps @Jussi_Aaltonen would have some ideas about why it doesn’t work?

//Rolf


PS Why can't we just have the option to download the plugins, like in the good old days?

Hi @RIL

Have you recently uninstalled a Rhino 8 WIP?

Can you get PangolinMesh installed using the Package Manager in Rhino?

Yes, that worked.

I actually didn’t know about the PackageManager, but now I do… Thanks!

I had installed R8 WIP, but I had not uninstalled it.

//Rolf

@fraguada
Is there a way to reset how food4rhino tries to open the install link? It appears to be using URL:rhino8 and if Rhino 8 has been uninstalled (or perhaps installation location changed) it won’t work.

@Jussi_Aaltonen
This is not a F4R issue, it is a browser issue. You can easily change which application handles the install:

Alright, thanks. So I had checked the “Always use this application…” option on my Chrome. I was able to bring that dialog back by following the instructions here. But Chrome appears to not have an option to choose between applications - nor does Edge.
image

@RIL I could not figure out what you could do to make food4rhino work for your Rhino installation.
I suppose you could try another browser that allows selecting which Rhino to open. @fraguada might have some recommendations there.

Perhaps the installation folder changed if you went from WIPs to Betas for example.

Hm, today the link works! Did you change something on your end?

A few days ago I had installed the WIP. I didn’t download the dedicated Beta (different?). Anyway, this is what was installed

image

The difference on my end is that yesterday I added a R8 licence to the Cloud. Perhaps the problem was that the link would not work on WIP unless having a R8 license?

Anyway, I use Brave and also Dissenter, both are Chrome based.

// Rolf

Nothing as far as I know.

I guess guessing doesn’t help :slight_smile:
If the browser complains that the application is missing I suppose the .exe is not in the path where browser expects it to be. Your version of Rhino 8 must have been an Eval before you had a license.

Hopefully PangolinMesh works now. Notice that in Rhino 8 you need to use the PangolinLayers command to popup a special Layer control that will allow you to drag layers to the PangolinGroups list.