Panels choices limited

When I click on the ‘panels’ menu at the very top of the screen and I get the pull down showing which panels are checked I find that materials (and others) is not checked and when I try and click on it to display the materials tab, it will not respond. How do I enable the material tab if I cannot choose it in the panels pull down like it has always seemed to behave?

I am unable to access my material tab in any of the following ways:

Where can I find this command?

There are several options to find the Materials tab.

  • images/materialtab.png Materials tab
  • images/icon-render.png Render Tools toolbar > images/materialtab.png Material Editor
  • Menus > Render Pulldown > Materials Editor
  • On the Command line type MaterialEditor

If I type MaterialEditor in the command line as above it autocomplete to ‘Materials’ and if I keep typing the full command as above nothing happens. How do I restore my Materials tab?

Make sure that under Tools > Options > Plug-ins the following are enabled and loaded: Renderer Development Kit, Renderer Development Kit Eto UI

That seemed to be the problem. Pretty obscure thing though. Thanks!

For some reason these were set to not load. How or why I don’t know.

I recently load protected Thea render plugin as it seemed to be the cause of many crashes as I mentioned in another thread. I also load protected some other plugins at the same time just to eliminate old plugins that may not have been updated to R7. I just went back and looked to see what I could turn back on as I got tired of having the ‘do you really want to not load this plugin’ everytime I started Rhino. I see two plugins in the render developement kit you mention and one was load protected but now that both are enabled I have full access to the panels. Funny thing I noticed is that when you click in the box of an unloaded plugin the list seems to jump up several items and that makes it easy to select the wrong item. Not all items do this jump but it seems buggy. Not sure if I can replicate this behavior but here are your two items I believe.Thanks for your help and advise!

When you have disabled plug-ins and you don’t want to be asked about them every time you start Rhino uncheck the box at the bottom of that Plug-ins page that says Ask to load disabled plug-ins.

Thanks, never knew that! Do you have any ideas why my Thea renders seems to not play well with the new Cycles stuff in R7?

Sorry, I don’t know. You will have to ask the plug-in developer.