Panel properties

get this trying to change the font size of panels:


goes away after recomputing the defintion

also end up with this disturbing effect:


1 Like

Cool @DavidRutten, :stuck_out_tongue_winking_eye: another easter egg. A little grim but fun.

Hmm, I wonder if an unsupported font style (bold, italic) was chosen. You’re saying it only happens once and then goes away on its own?

You’re using metahopper to change the panel when this happens?


Can you consistently reproduce this? Does it happen every time you try to adjust the font size or only sometimes? What font/size/other settings are you using?

Don’t know. it’s going to take less time to recalculate definitions when this occurs than answer those questions

Then I can’t very well fix the problem or help you out :laughing:

I was changing the text size, not the font

I am also looking for a way to batch resize the font in 50 or so panels of a GH file. I’m not sure if I’m going about this the right way, so any help would be fantastic. I selected Panel A as shown below and was able to successfully resize the font in that panel but it has no effect on Panel B. Is there an automated method to resize the font in all panels in the GH file?

I tried the SameType component but with no success. I’m probably using it incorrectly.

Any help would be appreciated!

I was able to recreate Footcandle’s display error. It happened to me just as they described. The spooky “Parameter is not valid” message goes away after dragging the Panel. It is ominous, though, and it’s not clear if it is related to any of my other struggles with getting the font size to change in all panels.

Close — try this:

you might have to drag all the panels a bit after setting the value to force them to redraw.

This worked for me - thank you so much for your help!

I found that recomputing the solution (F5) also forces the panels to redraw.